Missing fonts in prototype - Interactive components

Same error here, using variables in my prototype always having Missing fonts

Still exists. Still ruins your day. :smiley:

Having the same issue. Worked fine forever, now all of a sudden all my fonts are breaking on hover. What is going on here??? please help

Not a fix but maybe helpful,

This happened to me - After a ton of trial and error I found that my interactive components in prototype were only breaking when I was doing a lot of trial & error to get the effect I wanted. (aka adding new elements to the different components, then deleting, etc.) When I redesigned and reattached the items and it worked again (with no missing fonts message)

Same here, the prototype has missing fonts in the browser and also in the Figma iOS App.

The problem was, that the prototype contained heavily modified components that Figma could not update but only restore. After detaching all these components and its children, it worked all perfectly and fixed the problem.

1 Like

Just encountered this for the first time. Very disappointing bug to have to explain to a client. Disappointing to learn that it’s still here after 2 years. If it helps - this was with an adobe font that I have loaded locally.

Two and a half years later, this is still a problem. Prototypes work fine for me and my peers but when a client views the prototypes, the text disappears when there’s an interaction like hover or change to. Yes, component properties/variables are being used on the text.

The whole point of having variables is the power of using them!
Please have your team revisit @Josh

1 Like

Have also just run into this issue. Component properties/variables are crucial for interactions that help bring the prototype to life! Converting to outline does work but it makes adjusting designs afterwards complex.

I encounter this issue because my prototypes use a custom font that has been added to our Figma team. The custom font will work perfectly while viewing the prototype in-app & in browser if I’m logged in (essentially giving me access to the font). If I open the prototype in incognito to simulate the client experience then my components that use the font and have instance swapping will break (worth noting that the font works fine otherwise).

If I change my prototypes to use Arial font then it will work as expected in both cases. Probably because it’s a standard font that everyone has locally? There’s clearly an issue with custom fonts and component variants in prototypes.

This bug has existed for years and I have the problem almost every day that the fonts are replaced. I have tried all possible tips in the forum without success. Does anyone know if Figma has ever commented on this problem? Has it ever been confirmed?

Figma is developing more and more features and with every release you get the feeling that the bugs are growing just as much as the features.

Don’t get me wrong, I love Figma and Figma does a great job. But the old bugs should be fixed, at least some feedback would be helpful (but maybe I missed it)

I got in touch with their support team a couple weeks ago and got this response:

It appears that you have encountered a long standing bug that the engineers are aware of.

If this is something you would be interested in, I would be able to create a bug report for the engineers to investigate, however, due to it being a long standing bug, we will not be able to provide an estimated timeline for a resolution.

I understand that this is not an ideal solution, but please know that we are actively working on improving our platform and addressing issues like this. We appreciate your understanding and patience as we strive to provide a better experience for our users.

As a workaround for this issue, we have the following:
· Replace the custom fonts with a Google font, which will be available on every device that runs Figma prototypes
· Have the client/whoever is looking at the prototype install the missing custom font

So yes, they’re aware but don’t seem to be in a rush to fix it.

1 Like

Thanks for sharing your response, James. Unfortunately, the recommended “workaround” from Figma has nothing to do with this bug. This is not about missing fonts on any devices, but about fonts that are simply no longer found during the use of the prototype (use of interactive components and variables).

Thanks anyway, maybe this problem will be solved one day. Now that the interactive components no longer have beta status, such blatant errors should no longer occur.

Personally, I find the bug annoying, as such things often happen during a presentation with customers and shareholders. It’s irritating, looks unprofessional to outsiders, as if the prototype wasn’t built properly and weakens the user experience.

This has been an issue for me for years at this point. I have to tell my teams not to use Figma prototypes because they are so unreliable. It’s insane. If Figma worked as advertised, I can’t even imagine how amazing presentations would be. I would use it ALL the time. But unfortunately half of the product is broke with no resolve in sight.

1 Like

Still there to this day, using the font Oslo. I have never got that before so I suspect it might be font related. Would be interesting to prove that assumption.

Same problem here with FontAwesome Pro. I am observing this behaviour while doing remote testing. Doesn’t happen often but when it happens it ruins everything in the test.

I am also noticing that spacing of buttons stops working, the label goes outside the button and the button doesn’t expand.

To be honest a lot of problem while testing with Figma.

Was this bug magically fixed last week?

Or just working for me on my machine for some reason all of a sudden?

Nope, no magic, still an issue :frowning:

Wow from 2021 til 2024. After almost 5 yrs, it still happens to me. I used Arial and it still cracked.

I encountered this issue today using a test version of Domaine Display (a paid font - the test version features limited glyphs).

The trigger for my design seemed to be where font styles were switching to an underscore on hover. Removing the underscore resolved this issue.

@Figma team, PLEASE FIX THIS!

1 Like