Missing fonts in prototype - Interactive components

Having similar issues. Just started to notice them a few days ago. The funny thing is I am literally using Arial. How can it not find Arial. I’ve had these button components working as variants since the beginning of the year, only just now had an issue. I can’t even try to replace the fonts because it doesn’t give me an option, just talks about automatically being replaced. Tried restarting Figma and reloading tabs, did not solve problem. I had to detach all of my buttons to get them to display properly.

Potentially helpful context: I only see the yellow missing font notification when previewing my prototype. In the main Figma design file there are no indications of font problems.

Message: Missing fonts in interactive components. This file contains interactive components with missing or local fonts (Arial Bold). These fonts will be automatically replaced inside interactive components…

Hey Amanda, we just pushed a fix for a bug we noticed to day with our local font agent. You might need to restart your computer but this should hopefully be fixed now.

Not 100% sure if it’s related to what you’re reporting but would be great to check and see. Thanks! :slight_smile:

Thanks for the quick reply! Unfortunately after restarting my computer, checking for Figma updates, and reloading Figma tabs, I’m still seeing the yellow font error on my prototype preview. I checked and other Figma files using these same button components also show the error on the prototype.

One thing might have been fixed however. Yesterday in the prototype preview the buttons were actually displaying with the wrong style (why I had to detach them). Today, when I place a new button component in my file, the text is displaying correctly (bold) in preview even though I still have the yellow font warning. So maybe the font display issue itself has been resolved and we just need something else to clear that yellow warning? Unsure exactly. But thanks for looking into this.

Remarkable issue, definitely needs fix!
One unsustainable workaround what I’m using now is to unlink text from style in interactive elements.

Experiencing the same thing. All 3 designers who are on our project have the exact same copy of Archivo (a Google font) installed. We see no issues when in design mode, but in prototype preview we get the little yellow “A?” in the top bar. When you click on it this modal appears:

Any idea why we would be seeing this message only in prototype preview mode?

Hey all so this may actually be expected behavior. See this post here: New missing fonts behavior in interactive components

this is still broken for figma mirror (at least the ios version)!!

1 Like

PLease consider reading my last answer in this post, in hope it may help some of you guys. https://forum.figma.com/t/new-missing-fonts-behavior-in-interactive-components/7252/10

Still experiencing this issue and, due to Murphy’s law, it’s popping up right before a board meeting. This must be fixed.

1 Like

Mar-21-2022 12-02-12

Hello Figma crew, this is a very bad, recurring bug. Has been happening ever since I can remember.

Some prototypes just don’t render a few spots where an icon font is used. These spots that Figma “picks” to not show are random when first creating the prototype, but when replaying the spots remain the same.

Sometimes during the presentation, the icons appear and disappear as shown in my attachment.

Please fix this asap. It should’ve been fixed ages ago and it has given me and my team a lot of grief over the past year.

3 Likes

We continue to experience this intermittent issue as well. Because interactive components are, of course, leveraged in demos with audiences that include potential clients, stakeholders, and leadership it, this bug really affects our ability to trust and rely on prototypes.
Discussion on related threads imply that this is no longer an issue as of the October release. I can confirm that we are still experiencing the issue as of March 2022.

1 Like

We also still have problems with it and cannot rely 100% on the correct rendering in presentations. Especially when the link to the prototype is sent to the customer, there are discussions about wrong text formatting which does not reflect well on our work. The topic still isn’t solved!

1 Like

Any news here? Still not working.

For anyone still experiencing this bug, I just found a workaround. Hopefully this will also work for you:

Simply type a space before your icon font. That’s it. In my case it works perfectly, since the space character is not mapped on my iconfont it doesn’t push the icon or anything.

I can confirm that for me simply going into the textbox of the icon, setting my keyboard cursor before the actual icon and pressing the spacebar will fix the prototypes.

Cheers

We were having problems with this one also. Our solution was to flatten the icons and use them as components. This was a little bit painful process but we did it and now we have the benefit of searching an icon by name, unicode or description in the Component Search (the component description is filled up with those properties)

Hi, I created an interactive component that worked fine until one week ago (more or less). Now, when you hover on it the font changes and shows the message “Some missing fonts were replaced”

Please fix this bug in Figa. Some of my friends can only work in Figa. The rest are without font and no font can be found on Figa. :neutral_face: :confused: :confused:

My team is noticing this issue occurring during user testing as of 10/03/2022. Is there a clear solve for this?

I am experiencing the same issue.

We are having the same issue, breaking our usability tests up to a point where our data is truly useless. What’s the status on this and did you guys figure out what is going on?

1 Like

Facing the same issue.