Missing font style when variables change

Same issue here…

same issue

Hi all,
Thanks for flagging this! To give you an update, our engineering team are still investigating this issue - while I cannot set an ETA yet for the fix at this time.

This issue is specifically happening for locally installed fonts, so as a workaround if you use one of the Figma system fonts instead, this issue will not occur. However we are working on resolving the main issue here soon.

Thank you all for your help here by reporting this, and your patience while the team work to resolve this issue! We will keep you updated. :pray:


Same issue here

Same issue here.

Hi guys…
I had the same issue. But then I read one important thing in the Figma file for Advanced Prototyping by Figma you should check.

Order of actions matters. When you have multiple actions, they are run sequentially from top down. Therefore, when you have “Change to” interactions with interactive components, place that last, otherwise the component will switch before other actions are read.

So I tried it and it worked. Change the order and place the “Change to” action to the bottom and the “Set variable” actions to the top.
Screenshot 2023-08-02 at 15.26.07

But in fact, the issue comes up with locally installed fonts.

Unfortunately, this didn’t work for me :frowning: However, I’m using “Navigate” instead of “Change to” so that might be the culprit.

Having the same problem with no change-to actions.

Same issue here with the locally installed font Roobert. Switched to a Google font and everything works. Looking forward to a resolution.

Same Issue here

I have the same problem :cry:

Figma system fonts are no good for prototyping iOS/Android apps where SF Pro/Roboto are needed.

Same issue

Same issue here

Managed a fix here. We uploaded the typeface to the team library and now it all works

1 Like

hey, there is a workaround we found, upload the typeface you are using (that you are having issues with) to the Figma team.



note: this is for enterprise only

Same here :frowning:

I’m having the same issue. Any response from the Figma team?