Figma Support Forum

macOS Desktop app not installing

Figma desktop app - macOS

So, first of all for me the check for updates feature never worked. I click on it and nothing would happen. The only exception to this was when I actually checked for updates after a fresh install for the app. I usually just downloaded the latest version and then installed it manually.

Now, for a while the new versions available won’t install anymore and the app gets broken.
I tried everything: overwriting, fresh install. Same issue.
Here’s what happens:

  1. I copy the app into the Applications folder.
  2. I run the app.
  3. I get this progress window:
  4. After that’s done, the app is broken:
  5. When I open the broken app I get this:

I tried this a couple or times in the past month or so… same result.

Anybody got a fix for this? I’m currently stuck at version 97.7 which is the last one that works on my mac.

Thanks!

3 Likes

It will be helpful if you specify the version of the operating system.

You can also contact support: Submit a request – Figma

OS version: macOS Catalina 10.15.7

These builds should work:

In order to fix the installer, it would be useful to know some more info:

  • Are you installing to /Applications?
  • Does your user have write access to /Applications?
  • Does auto-update work for other apps you have in /Applications?
4 Likes

I have the same problem but on Big Sur 11.2.1

2 Likes

Thank you! The Intel build worked. I now have the (latest?) version: 99.0

Now I am wondering why the installer downloaded from over here does not work?
There is also a difference in size from the one you linked (88 MB vs 1.2MB)

How should I run the update in the future?

To answer all three of your questions: yes to all of them.
I use a regular account to work daily in Figma, but also use an admin account to install/move apps into the Applications folder.

Thanks!

I, and others had this issue as well. We reverted by installing an older Installer which is a lot “bigger”. The installer which downloads after the move to the applications Folder (installer around 1.4 MB size) always fails for us.

We are running 10.15.7 Catalina. We do not have permanent admin rights, but we can get admin credentials for a limited time frame and move the app into the applications Folder.

1 Like

I am also having the same issue, but @poiru 's download suggestion of
“Apple Silicon computers: desktop.figma.com/mac-arm/Figma.zip” download still produces an error message for me.

  • I am on macOS Big Sur 11.4

  • I am installing it to /Applications

  • I use an admin account to install and move apps to /Applications

Screen Shot 2021-07-19 at 5.55.57 PM

Is there another workaround for this, besides always using the browser version?

This issue happened here too.

Device: Mac Pro w/ MacOS Big SUr ver.11.2

Figma asked me to upgrade by downloading the latest ver. on official website,
or I couldn’t continue using it.

Then I :

  • download the installer

  • drag it into “Application”

  • became plainly white and failed to launch after installing

(it happened the same when I removed Figma before updating)

I will be really appreciated if there is any way to get it installed.
Thank you.

The intel build worked for me as well but I had the same issue before.

2 Likes

Thanks for your sharing. It works!

I have the same problem on macOS… the problem is that I lost also the old version and I don’t know how to put it back.
Dose anyone know how to fix it? @Figma… please help

The Intel Version helped thx! Had the same Issue as Alex

I had the same issue and the Intel version worked for me, Thanks @poiru :+1:t5:. Maybe the “Figma for desktop and mobile” page needs some attention, the file I downloaded from there lead to the same issues experienced above.

Thanks @poiru, this should be updated on the Figma website, I just download the Mac version now and didn’t work for Intel Mac, luckily I found this thread

Same issue with me Big Sur 11.4

I have the same issue. The Intel version worked for me. Using MacBook Pro - MacOS Big Sur 11.5.

I have the same issue on macOs Catalina v10.15.7 - the small (< 2MB) version always failed after downloading the update (it left a zero-byte Figma.app in my Applications folder)… buit the big linked Intel version just worked.

Why not just list the big Intel version at the download page, given it has to be downloaded anyway?

thanks! I was struggling yesterday with this issue!

The intel version worked fine! Figma you should update the file in the download page.

1 Like