Libraries enabled but components are not showing

I am new to Figma (transitioning from sketch). I just had to buy the professional plan to experiment with libraries. And thats where I got stuck:

I have a library file ‘documentA’ published and enabled for my team in ‘document B’ (I am on the pro plan). But I cant see components! It just says “…explore libraries…” and when I click on it it shows me that my library is enabled.

I hope this makes sense — I’d love to upload screenshots here but I dont see any option to do that. Is there actually a way to get real customer support?

Thank you in advance for your help!

1 Like

Update: I also have ‘enable and set default team to libraries for all team files’ enabled!

I have the same problem, did you solve it??
It’s driving me nuts…

1 Like

Same here… any clues?

Turns out that my components were grouped and it worked after I ungrouped.

Same problem. I do have the components in a frame, so what? Can somobedy from support chip in?

Hi!
I’m new to Figma, so sorry if my terminology is limited. The way I fixed it was by going to the Mobile Wireframe UI Kit on Figma, and clicking on ‘Libraries’ from the Main Menu drop-down > I saw that there were still about 395 components that weren’t published when I first did it from the drop-down by the file name > After publishing the rest of the components, I went back to my team project design, and the components just showed up.
Hope that helps!

Update: I duplicated the process, and the problem happened again. I then repeated the process on the desktop Figma application instead of the web browser and it worked there instead.

I believe it may be a bug on the website browser.

I had something similar happen to a library where I had a 3 separate components in a Frame for organizational purposes. Two of the three components appeared in my external file that used the library but one did not. My issue was that one of my Variants did not contain all of the Properties. Once I included all of the Properties to all of the Variants and published the library, all of the components appeared.

1 Like

The solution is very simple. Check that your unpublished components doesn’t have errors (mine had an unused text) I fixed it and voila. Working as expected.

4 Likes

¡Damn it! It happen to me now. Yesterday I had whole stuff from a published library (DS) and now the “colors” disappeared. I have to “copy/paste properties” but with new elements can not resources to copy. Figma bug? Any clue? :melting_face:

Reboot my Mac, install an Figma update (at the same time) and solved this issue. In my team, I was the only member with this issue, so I invite to do the same every time Figma fails.
Hope this help. Regards everyone.

Hi there,

nothing of it worked for me, unfortunately. So I had to detach & recreate the components & publish them again.

1 Like

Hey everyone be sure you have opened the Library File on Figma and double check the following:

  1. Libraries are enabled.

  2. The design file has been moved to the project you are working on.

  3. The design file has been published.

  • Step 1 can be completed by clicking on Assets → Team Library icon (looks like an open book) → Clicking “Enable libraries for all team files from your team settings” hyperlink at the bottom and following the prompts

  • Steps 2 and 3 can be completed by clicking the drop down arrow located next to the design file name at the banner on the top of the page

After the above is completed navigate to your Design File Project → Assets → Libraries. This will display the Library and Components you have linked and should also have the button to enable/disable the library on your Project.

Hope it helps!

1 Like

This solved my problem. Thank you so much :slight_smile:

hey guys I’m new here, how do i find mobile wireframe UI Kit?

worked for me, thanks!