Is there any way to enable “Spread” option under drop shadow for a flatten vector?

When I flatten a vector, the “Spread” option under drop shadow will be disabled.
Is there any other way to hack or enable this option under drop-shadow?

1 Like

:smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear:

Shadow spread is only supported on rectangles, ellipses, frames, and components.

Did you try making it a component?

1 Like


still doesn’t work :smiling_face_with_tear:

I don’t think there is a way around this constraint, but one hack I’ve found is to duplicate the vector and use “layer blur” effect to emulate the spread parameter.

@daken spread for shadows can only be edited when the frame you’re working with has a fill. I’ve found success applying a fill and setting the opacity of the fill to 0.0001 (which will register as 0 in the input, and effectively invisible on the canvas). You also must make sure “clip contents” is turned on.

Here is a GIF demoing how to do this in Figma:
spread

And also Figma’s documentation on drop shadow spread.

2 Likes

that is great

1 Like

The component/frame etc. needs to have the “clip content” checkbox selected in the Frame section in the design control panel (top left of the screen) in order to apply a spread to a dropshadow

1 Like