Interactive components not working when nested inside a main component

The solution doesn’t work for me. I’m still having this problem when trying to apply interactions to nested instances? My product card is an instance of a component with 8 variants and instances of components inside it, like buttons etc.

I can’t set the “change to” interaction on those buttons unless I detach them inside the card component - you can see in the GIF it won’t accept any changes to the properties, it just instantly reverts back to its original state

May-30-2022 11-19-00


I’m having similar yet different issues. In any case, all are caused by nesting interactive components.
How come there’s no official answer or solution to this? It’s incredibly frustrating to work for hours on something only to find out that it’ll never work due to bugs. It’s also annoying that this forum tells me that this issue is resolved when it’s not…


@Figma_Support This issue isn’t resolved


Same issue! This topic is NOT solved


I’m having this same issue.

1 Like

I have the same problem. So I tried something.
My case: a nav bar, with links to sections, each section icon is highlighted. Creating a variant for the nav bar breaks and linked interactions, within the component.
Instead of clicking the + button, I did a duplicate.
That duplicate becomes a variant and preserves linked interactions.

It still needs fixing please Figma.

Adding to the growing list of people experiencing this issue.


Same issue here.

Same issue, not beign able to prototype correctly in nested components

1 Like

Same issue, just happened today. Please fix!!

1 Like

same issue

I used some interactive components and now all of a sudden the option from the sidebar is gone and i am not able to prototipe correctly

Having the same issue as others above with a navigation bar. Adding buttons with no fill on top of the nested component to change the other component’s variant states was an easy fix, but not ideal.

facing same issue.

I’ve got this too. Can’t select options in the ‘change to’ menu, which is plain baffling and I’ve wasted the past hour trying to fix…

Having an issue that may be related. It seems like making complex swappable interactive components with autolayout leads to problems. The prototypes don’t match the how the components look in the frame.

Yup, just run into this myself, definitely not solved.

It’s annoying to put so much time into combining instances / adding variants / building interactions between them, to only find out later none of that works when needed.

Please fix.


I had the same issue, but it was fixed after I discovered two variants with the same name (I forgot to update the new variant name), and that fixed the issue when clicking the variants in the interaction pane wouldn’t actually update the variant. Check your variant names!

1 Like

Absolutely not fixed @Figma_Support


Thank you for the fantastic answer! Honestly didn’t even actually read at first— your Figma solution link is so clear and self-explanatory that it made me instantly realize how to solve this.