"Import plugin from manifest" does not work inside FigJam

When I’m inside a FigJam, right click > Development > Import plugin from manifest… has no effect. The selected plugin does not appear in the list of plugins under Development section. I was able to repro the issue with a vanilla plugin generated by Figma

Screenshot 1

Screenshot 2

Additional observations:

  1. The plugin does appear in the Figma files and account Settings > Plugins tab. The issue is only with FigJam

Screenshot 3

Screenshot 4

  1. I tried uninstall, reinstall Figma. No luck

  2. I tried clearing Figma cache but it throws error.

Screenshot 5

Screenshot 6

  1. No log observed in developer console or internal developer console
  2. This issue has also affected the plugins I have already published. They appear as local file is missing. Clicking “Locate local version” and select the local manifest file has no effect in FigJam.

Figma version: 116.9.5, I also repro-ed the issue on another PC machine running 116.6.3

Thank you for reporting this to us and for the detailed report! Our engineering team is actively investigating the issue to determine its root cause.


Update: I have my friend tried it with his Mac and it has the same repro. So something seems to be seriously broken across all platforms. I think other developers might be impacted by this too.

Same here! Our team is also blocked by this. Local FigJam plugins are no longer showing up :frowning:

1 Like

Thank you everyone for reporting this issue.

Update: Our engineering team has push a fix for this.

Please refresh Figma to ensure that you are using the fixed version. If you continue to experience the issue, please let us know and we will flag it down for further investigation.


Since today, May 25, local developing plugins are not running in FigJam. I get the notification that the plugin is loaded, but nothing else happens, nor the plugin appears in the plugins/developer context menu.

The bug has been fixed very quickly.

1 Like