How to NOT preserve scroll position when page transition with Smart animate matching layers

With “Smart animate matching layers” turned on, every time we click in the prototype the stuff moves to the same scroll position on the other page instead of going back to the top.

“Preserve scroll position” setting is not available with Move in/out, Push or Slide in/out options. How can I reset the scroll position with those page transitions?


wondering the same thing

I have the same issue i want to use the smart animate but it takes to the same scroll position while i want it to go to the top of the page and there is no option to chose from…
I see many threads about this issue, can you react Figma?

1 Like

I think this is something that will be really useful, our prototypes on Figma have this issue as animation-wise it looks best with smart-animate, however it preserves scroll position which looks strange.


Has anyone figured this out?

1 Like

Bump. I need this too.
Making a zoomable map on click and I want it to be centered on the user’s icon when transitioning. Atm that’s only possible one after another (first smart animate transition, then after delay scroll to for the map - really annoying!)


I thought I was crazy. This is very annoying.