“Go to main component” button is gone (read below)

oh wait, suddenly i can edit anymore. even though i’ve been a main editor since the file was created. this is absurd, really. what if the person who created the file is no longer on the team and can’t be communicated with? I also have a vague memory that i created the initial file, a copy was made, and the initial file was deleted in favor of this one. shouldn’t my info be maintained somewhere? Shouldn’t the file have given the owner a message the first time they opened it that they were now the only editor unless permissions were granted again?

Ran into this problem today, where the developer could not see the “Go to Main Component” option listed, even though he had viewer access to both files. The problem appeared to be that the gained access to the Design System file via a link. After manually inviting him to the DS file via email, the problem was solved.

I created the components and now I cannot go to the main component to update numerous instances? Do I understand this is the case? I don’t know what the trigger would be as others have suggested in the replies…

If so this is a big, cumbersome manual set of updates I am in for!

I also encountered this problem. I created a document in the Drafts section and linked it to a library in a specific project. However, the link between components in the file and the components in the library was not displayed. Moving the file from Draft to the project solved the problem. However, this indeed seems like a very strange and non-obvious solution.

1 Like

Any news on this? Keeps happening for me aswell, whether the file is in the same team and project of the design system file. It is just so random how this go to main component disappears

This is still a very annoying issue.

image

I can’t go to main component even though the file where this component is was created by me. The issue I guess is in that this file is in a different team from the current file. Both files and teams are owned by me.

I was having this problem, no link to the master in the team library. But then realized the file I was working in was in the Drafts section. When I moved it into a team project where the library is, the links reappeared.

I’m okay with this, but it’s a weird distinction. “You have complete access to all components in the team library when your file is in Drafts. But no master-instance links for you!”

1 Like

Moving the projects into the same team worked as a fix for me.

It doesn’t make sense for projects to have to be in the same team in order for the links to work. That should be changed. Everyone experiencing this issue is evidence of how big an issue this is

This fixed it for me too, thanks!

Glad to hear Joseph’s suggestion worked for you both!

Please let us know if you run into any further issues.