Flickering or Missing Icons in Prototyping

Hey, team,

I’ve been working on a prototype in Figma, but I’m encountering an issue with flickering icons during transitions between frames. I’ve tried troubleshooting it, but I’m not having much luck fixing it alone. Please help me look and see if we can figure out what’s causing it.

Here’s a summary of the problem:

  • I have two frames with similar icons (minimize, maximize, and close).
  • When I use Smart Animate to transition between the frames, the minimize and maximize icons flicker.
  • I’ve checked for consistency in layer properties, positioning, and Smart Animate settings (I even tried using different settings), but the issue persists.

Any insights or suggestions on how to fix this would be greatly appreciated. Thanks in advance for your help!

Hi there,

Thanks for reaching out. Smart animate looks for matching layers that exist across multiple frames. Figma takes into account both the layer’s name and where it sits within the hierarchy . It seems like your layer hierarchy is consistent, but could you try renaming the specific layers to match the others?

When I encountered a similar issue, aligning the layer names seemed to resolve it in my file. If the issue still persists, would you be able to share the file link with access to support-share@figma.com? It won’t affect your billing. I hope I can investigate it further.


Hi, I have a similar issue!
The interactions I am using are: open overlay (move in - bottom - ease in and out - 300ms) on tap and close overlay on drag. The issue I have is the following:

When the overlay is open and I try to close by dragging downwards, then it works well. However, if I accidentally drag in any other direction (left, right, upwards), the overlay starts flickering.

This happens only on the phone and not on the computer. I have tried this in several phones (both android and iPhone) and the issue remains. I think this started happening after the latest update of Figma (beginning of May 2024).

It would be great if you could provide us with any support to resolve this issue, thanks!

@Yamen1 @Christos2 thanks for the information! Since we have multiple cases, it sounds like an unexpected behavior. Could you submit a bug report detailing the steps that led to this issue? You can do so by following the link: https://help.figma.com/hc/en-us/articles/360041468234-Submit-a-bug-report