Figma ran into a problem error

Trying to resolve conflicts in a branch before merging, the conflicts are not loading and after some time the screen turns blank with the error showing ‘Figma ran into a problem’.

Unable to merge a branch to main file. Need support?

1 Like

Hey Kriti_Jain, this could happen when you don’t have enough memory. I’ve followed up via DM, please take a look when you have a moment.

I have the same issue. The memory sizes in both the main and child branch (both are less than 35%). I was able to merge yesterday but not today. How can I fix this so I can merge the child to main branch? Is this a bug?

1 Like

Hi, I have the same problem. I need help as well
Please contact me

Hey @Gayani_S , my orgs team is facing these same issues post todays update. Our workflow has come to a halt. It does not look like a memory issue as some of the files having issues are well under 15% utilization.

1 Like

Hey @Kriti_Jain , did you find a workaround this?

I have the same problem. I need help as well Please contact me.

Hi. In lieu of the memory problem, how about having a way to completely bypass the “Review and” part of “Review and merge changes.” For example, I’m totally aware of what’s different in my branch than the main file. I don’t want to review it. I want to force the branch to become the main file.

No attempting to load all the differences that only lead to a File out of memory error. Just force the merge. Can that be an option?

hal yang sama sedangjan file tidak banyak, gimana solusinya ?

apakah sudah teratasi?

Hey @Ade_M, if you’re also seeing this error message then your merge might exceed Figma’s memory limits.

Our Help Center article Reduce memory usage in files has more information on this limitation and how to avoid hitting it. For branches our engineers have the following notes:

  • We encourage users to update their branches often and merge them quickly; the larger the difference between the main file and the branch, the more memory we need to use during the process.
  • General tips to split up files and large libraries that apply for reducing memory usage in files also apply to branching and merging. We do understand though this is not that useful for large design systems which commonly include branches.

If you have any further questions or concerns, please do not hesitate to reach out to us. We are always here to assist you.

hi there , i am experiencing the same issue with Figma saying it has ran into a problem. how can I resolve this

Hey @onsetwithaaliah, thank you for reaching out! I am able to get you connected to our technical quality team. Before that can you please confirm if is this is happening in the browser, desktop app or both?

Can you try clearing out the cache? Here are some information to troubleshoot:

Troubleshooting checklist

My files are not opening

Also, please try to force-quit and open Figma in a new browser window (or force-quit the Figma Desktop app and restart it.)

Please let me know if this resolves your issue?

Hey @Gayani_S we are also facing merge problems with the same error message as described above. Tried the following troubleshoot you mentioned without any luck.

Hey @Dennis_Johansen, thanks for confirming! I’ve just created a support ticket on your behalf. Our technical quality team will be able to investigate further. Your ticket number is #947324, for reference.

Please share your console log with our team: Export network logs

Our support team usually takes up to 24 hours to reply back to emails - tends to be quicker than that in normal circumstances. However, please be aware that we are facing increased contact volume so there might be a delay.

Let me know if you have any further questions.

Thanks,
Gayani