Figma links always open in browser, not desktop app

Hi @Lisa_Lessenger_AWF! We rolled out a fix a few days ago. Please try restarting & let us know if you still have any trouble!

1 Like

in browser figma there is no more 「Open in desktop app」
20210914-111213|392x500

It seems like the installation of the desktop app is not detected for some reason. Try reinstalling the desktop app and restarting your computer.

Reinstalling and restart not help for me on mac & google chrome v.93
Work only in safari

Try change link to figma://file/…

11 Likes

I had this problem days ago, and I’ve solved just restarting the Figma app (quit and starting again) on Macbook.

1 Like

Hey All, thanks for reaching out!

Can you please try the following troubleshooting steps to see if it helps?

  • logging out and back in
  • clearing your desktop app’s cache
  • un-installing and re-installing the desktop app

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf "$HOME/Library/Application Support/Figma"
  3. Try opening the desktop app again

You can clear the desktop app cache on Windows under the toggle-arrow at the right of the top toolbar under Help > Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Close the Figma desktop app
  2. Open the Start menu, and paste in this, followed by enter: %APPDATA%\Figma
  3. In the window that opens, delete the Desktop and DesktopProfile folders if they exist
  4. Launch the desktop app again
2 Likes

Will deleting my cache on windows also remove my settings? I have customized a lot of things and would need to know if this would make me lose anything. I ask this because the folder is named DesktopProfile which sounds like where settings are stored.

Hey @Eduardo_Mazieri1,

Clearing the desktop app cache will remove some settings in the Figma app, but it should only remove the settings specific to the desktop app itself (which there are very few). Most of Figma’s settings are stored to your account and will be preserved.

Hey All!

I found out why there is no way to open any Figma link in Safari.
You need to enable only the “Hide IP address from trackers” option in your Privacy settings.
Make sure to quit Safari completely and then reopen it.

All the best,
Daniel

6 Likes

and, of course, if it doesn’t work you must click on the “Open in Desktop App” when you’re link is open in restarted browser.

This randomly started happening for me (Mac, Firefox) and nothing I tried fixed it.

I ended up installing this Firefox extension which solved the problem for me.

I am using Velja: ‎Velja on the Mac App Store to work around this issue

I tried everything. Finally this helped, thanks!

1 Like

@dvaliao I have tried all of the three suggestion mentioned above: logging out and back in, clearing your desktop app’s cache, un-installing and re-installing the desktop app and I still can’t see the option to open links in the app in the preferences menu. Please advice me on how to proceed

When I tried to clear the cache the app didn’t respond and I couldn’t use it. I waited approx 10 minutes and then I force quit it, so not sure if that step actually completed the cache clearance or not

Hi all, does this “solution” on the top worked for someone? I tried it and I doesn´t change anything although after new login via browser and enabling in the dialog “alow Figma links always oppen in app”. Any ideas? (using Brave)

hi, I had the same issue with clearing cache …

I have the same issue. macOS 13.5.1, Firefox 116.0.3, Figma 116.12.2. Clearing the desktop app cache didn’t do anything for me, neither did reinstalling the app, or clearing the browser cache.

1 Like

I fixed it by disabling uBlock Origin on figma.com. Huh. You might wanna look into that.

2 Likes

This is the solution – thanks!