Figma Browser Memory Too High

Hi everyone, I’ve recently created a new Figma file and I’m getting the yellow browser memory banner. I have 45 pages but the majority of them don’t have any content and no hi-res images and only a few frames. Is there a way to pinpoint the cause of the issue I don’t understand how I’m getting this error. I would really appreciate the help everyone and thanks in advance.

1 Like

Hello there

Each tab of Figma can use up to 2gb of Ram automatically

check this Link to configure your browser:

I also strongly suggest using Figma App instead of browser

I’d recommend making the following changes in this order. The highest impact changes you can make are at the top:

  1. Reduce overall number of hidden layers. Removing non-critical hidden layers is the first thing Figma recommends doing in their documentation. If your components are using hidden layers, it could be good to check that they’re taking advantage of the boolean component property and not variants (related to the next item).
  2. Reduce variant count for larger sets. Deciding whether to use many variants VS splitting up a large set into multiple components can be tough. My personal rule of thumb is to keep variant sets below 50 as best I can. It’s a case-by-case thing, but I generally start to take a more critical eye to 50+ component sets and challenge myself to think about how I could break it up into multiple components without sacrificing instance usability. The links in this list item go to blog posts I’ve written which go into greater detail on these topics (if you’re interested).
  3. Compress high resolution imagery. You mentioned you’ve already done this, but if you still have memory issues after reducing hidden layers and variant sets, it could be worth compressing your images using a free app like ImageOptim.
  4. Simplify complex vectors. If you’re using detailed vector assets, see if there’s a way to reduce the number of nodes without losing quality of the artwork.
  5. Remove uncessary pages. You mentioned having 45 pages in your file. This sounds like a reasonable number to me! But if you’ve tried the 4 things above and still have issues, you could try deleting empty pages. Though at that point you might want to try cutting and pasting the material in this file into a new one.

Hope these tips help! This is a really frustrating problem to run into, so I get it. But after I experienced it myself it’s completely changed the way I work in Figma and I’ve been very careful to avoid it ever since. So far so good! I hope that this is the last time you have memory issues too :pray:

:mega: (EDIT UPDATE: January 13, 2023) :point_down:
After helping a talented designer from the community personally troubleshoot his memory-bloated file, I was inspired to write a blog post offering more strategic, specific instructions.

I realized telling people to “Reduce hidden layers” was leaving a lot of folks hanging :sweat: navigating a file that’s starved for memory is so painful. The rendering is choppy, Figma stops being able to keep up with your clicks and movement on the canvas, and making any edit takes what feels like a lifetime.

The last thing folks need to hear is another dismissive “rEduCe YoUr hidDeN LaYeRS”…

  • should you start with hidden layers in regular frames or components?
  • what’s the fastest, most direct way to find where the majority of hidden layers are in your file?
  • how do you make performance optimizations to components without losing overrides on their instances?

I dug in to all of these questions and published a clear, specific, strategic set of instructions that will help you revive your file. I plan to do some pressure testing on these instructions to ensure they not only hold water but are tight as a drum. For now, I’d love community feedback from anyone who uses the guide to let me know if it helped them :pray:


“I also ran into this problem not too long ago, but with a little bit of nosing around, I managed to find a solution. Here’s what you do. Firstly, open the settings of your browser. For me, it was Chrome. Then, just hunt for the ‘Memory settings’ section. Next, you’ll need to add the website that you don’t want to limit memory for. And that’s it! Easy peasy, right? Now, you can enjoy your Figma without any restrictions. Hope this helps!”