Create and merge branch feature are both greyed out

create branch and merge branch feature are both greyed out.

  1. I am editor
  2. both file owner and I cannot create or merge any branch, they are both greyed out.



Hello to you from 11h later. We’re experiencing the same issue. Thinking that may be a new bug.

1 Like

just quick communicate, is your Figma file also very heavy in terms of memory usage?

Hi, exactly. I tried to “check for updates → reload all tabs” and the option was enabled again, but now that you pointed out the memory usage I worry that’s only a temp solution.

Hey Phelix! If the “Create Branch” and “Merge Branch” features are greyed out in Figma, here are some troubleshooting steps to consider:

  1. Check Your Role: Ensure that you have the correct permissions. You mentioned you’re an editor, but double-check to ensure you’re not viewing the file as a viewer. Only editors can create and merge branches.
  2. Figma Organization Plan: Branching is a feature available to users on the Figma Organization plan. Ensure that your team is on this plan. If you’re on a free plan or the professional plan, branching won’t be available.
  3. Main File: Ensure you’re in the main file and not in a branch. You can’t create a branch from another branch. The option to create a branch will be greyed out if you’re currently in a branch.
  4. Active Selection: For merging, ensure you have an active selection in the layers panel. If nothing is selected, the merge option might be greyed out.
  5. Check for Updates: Sometimes, software glitches can cause features to be greyed out. Ensure you’re using the latest version of Figma. If you’re using the web version, try refreshing the page. If you’re using the desktop app, try restarting it.
  6. Browser Issues: If you’re using Figma in a web browser, try switching to another browser or using the Figma desktop app. Some browser extensions or settings might interfere with Figma’s functionality.
  7. Collaboration: If the file owner has restricted certain features or if there are too many collaborators on a file, some features might be greyed out. Check with the file owner to ensure there are no restrictions.

I’ve checked all 7 of these.

  1. I am editor, neither file owner nor me can create or merge any branch in this very file. However we can do branch in other files.
  2. Our organization plan covers everything in theory, at least we are able to use branching feature in other files.
  3. We are pretty sure we are trying to create branch from main and merge from a branch.
  4. We have active selection in the layers panel.
  5. We are using the latest updates.
  6. We tried every browser and Figma’s app, non of those works.
  7. There is no restriction whatsoever, at least we can do branch in other files.

I’m sorry but non of these steps helps. Could you check if a file with heavy memory usage will be restricted to some features such as branching?

Just quick note, we tried branching in other files and everything seems to work just fine. The file which failed to use branching feature is heavy in memory usage but all other files dont have this problem. At this moment we are not able to try with another heavy file so… maybe you guys can have a try?
I’m starting to think if memory usage causes this greyed-out-branching issue, but if yes, Figma should have tooltip or any notice when a mouse pointer is hovering the greyed-out text. Personally, I think this is just bad UX.

Hey Phelix, a late reply from me as I’ve reached out to Figma support team and indeed, they disable the branch option when there’s a potential for memory overload. Agree that’s bad UX, they could have explained why :pensive:

Hi Roxie, thanks for the info!
We also got a work-around for this… last week we assumed that memory load is the key issue to branching issue and we tried this and it worked, here’s the steps.

  1. create branch outside Figma file (instead of inside file), basically right click on the Figma file thumbnail you would like to branching on, and create branch. (I believe this might be a bug at this point, but it works for us)
  2. When merging is needed, clean all cache, and open the Figma file. Before the file self-detect and displays the memory warning at the top-left corner, quickly click merge branch and proceed. As tested, there is 1-2 second window for this operation so make sure your mouse hand is quick…

This work-around is probably just bug for now because it might cause serious memory issue at some point, but at least it works for us.

1 Like

That’s such a hacky workaround I’m clapping for your genius!! Seriously, fixing this should really be on Figma’s side… I hope they can address this soon. Kudos for your team, tho :smiley:

1 Like