Color gradient cannot be deleted

When I edit a color gradient, a certain point in the color gradient cannot be deleted.

1 Like

You need to select the color and hit backspace to delete it.

1 Like

I love when UX tools have bad UX. Figma is all over the place with this stuff! Haha.

This is not working. Selecting the color and hitting backspace is deleting the object with the color gradient applied to. Not the color inside the gradient.

4 Likes

Hello there! Thank you for getting in touch! As @dennsi already mentioned, you can delete by selecting the color and hitting the backspace key. Here is a visual supplement to guide you through the process.

Hope it helps!
If you are encountering any different behavior, please do not hesitate to inform us. In such cases, please share a quick video recording or screenshot of the issue. It would greatly help our community!

Also, I updated the category for this topic from “Share an idea” to “Ask the community.”

Thank you!

1 Like

Hi,

I try to select color and press backspace… but is not working.
Nothing happens when I do it.
And I’ve had this bug for 2/3 days, before that it worked normally.

Can you helo me ?

2 Likes

For anyone who might find this useful

If you have selected multiple objects with a gradient deleting one color stop on the gradient won’t work

Select one object with gradient at a time and delete the color stop
(Issue present at the time of writing)

2 Likes

same behavior here.

I’m also having this issue. It used to work before and now my object gets deleted whenever I try to delete an extra stop in my gradient. I think it’s a bug but if you’ve found a workaround, please let us know!

3 Likes

Same here. I tried Figma in the browser and the desktop app (on a Mac).

1 Like

gradient color cannot delete when in style mode…

2 Likes

Yes, I think this fixes the problem, but like a week ago I wasn’t having any problem changing the gradient of multiple objects all at once. I hope this is a temporary thing.

When you drill down to the layer with the gradient, you can delete the color stops. I was having this problem because I had multiple layers selected and was trying to change the gradient from here:
image
This seems like a bug to me and I’d hope it would be fixed at some point.

Hey all - if you’ve been seeing this recently, it looks like it may be a bug that’s already being investigated at the moment. I’m going to check on this internally to see if this is the case, and I’ll update here if I learn anything.