Changes published in library are not updating component instances in other files that use the library

I was in contact with Figma support for the past few days and it was fixed on my end, today i asked them is smt was fixed in the code by email so we’ll see. The message reappeared this morning to update the instances of a library components. I hope its back to normal for all of you as well.

I had some errors in the components that needed to be addressed. After resolving the errors it published and was updated across the files.

I still have these problems from once in a while… I wasted a day trying to fix it since it blocks me from progressing in the work.

UPDATE :warning:

I spoke to Figma and they figured out what happend on my end, maybe it helps some of you.

If you have variants applied to a library component, all labels must have a unique name. Figma displays a conflict error if variants have the same value, but if you have a library component and the setting labels are called the same, this conflict error is not displayed. The system recognizes it as a conflict and therefore it won’t update the component until it is fixed, so it will never show up in your updates, even if you think you have published it.

Make sure all labels in your settings are unique.

Here was my mistake to give you an example (see image attached). We have two secondary buttons in the toolbar library component. The value can be off/on, so no conflict there, but because there are two items called secondary button, the system cannot map it correctly and the “conflict” was never communicated to me, so I did not know this was the reason why my component would not update and be published.


Thank you! This helped me with publishing an update in library :+1:

  • In my case my work-file still didn’t suggest an update popup - so it seemed to be needed to relink the compoment instanses in work-file artboards - then it worked.

(JFI: maybe it will be usefull for somebody for relinking the component. I additionally updated the name of the main component before relink (just added some dot at the end) - thus I could see on the sidebar by the the name the difference and check which component is updated (or not). Seems like Figma in the work-file finally got this difference as well :wink:

For some time now I have not been able to update my design files that use the shared library. No updates are displayed. All the suggested solutions have not helped me out of this big problem :frowning: Maybe this is a temporary technical issue.

Maybe this is the reason today, found it on the status page

On August 25, 2023, Figma will be undergoing scheduled maintenance, starting at 4:00PM PDT/21:00 UTC. We are scheduling the maintenance window for 30 minutes, but anticipate Figma to be unavailable for only a few minutes.

During the maintenance period, while you will not be able to open new files or refresh existing files, you can continue to work on any files that are already open. When the maintenance is over, your work should sync as expected.

If you continue to work during this period we suggest also backing up your work by saving your File locally as a .fig file. This way, if there are any unforeseen issues, you can import your saved version and continue as normal.

We hope this will not be too much of a disruption and appreciate your understanding. If you have other questions or concerns please email or contact us inside the app.

I’m currently having this issue and found a hack to fix it. If I place a new instance of the component from the asset panel, I get the update notification and the subsequent instance updates. This isn’t helpful for all the other designers working with our library, however. I’m working on an emerging design system and we need to be able to trust that our assets are updating reliably!

I’m having the same issue. Having hacks is fine, but those fixes are not a long-term solution for teams working with shared libraries and projects.

I have the issue as well. New instances show the updates in the master components. Old instances do not. In my case, a boolean property is not showing up for the old instances, even though they point to the master component, which has the property. None of the mentioned solutions worked for me.

Same issue. Super frustrating. Grinds the work to a halt.

1 Like

Thank you so much! this works

1 Like

Having the same Issue – the Library Element only Updates If I manually add it again from the Assets Panel but that’s a big bummer and slow’s down the process tremendously.

I tried all Hacks and repairing connections but also making new Instances, relinking them, adding them as a new Component Instance and so on… just doesn’t work

Figma you seem to have a Problem here.

This is getting beyond a joke! Library updates will just not update in the design file. I can insert a new instance of a component and it will contain the updates from the LIbrary but all the instances that were in the design library will still not update.

From the library modal, if I go into Updates click on the component to review updates, the Preview is unavailable and on update instance I get the error - “An error occurred while retrieving the component or state group”.

I have tried repairing and nothing works.

I have been working with Figma for years and Sketch before then. In the last months there has been major issues with Figma. Its now to the point that it is having a huge impact on performance across the design team deliverables. So much so that we are considering switch to Sketch.


Same for me. It’s grinding my productivity down slowly. I have to restart Figma every time I need to pull updates into my design files from my library files. Its just not recognising there have been changes in my library files. It’s ben like this for almost a year. Please, please sort this. Figma is great, I really don’t want to have to switch tools … again

1 Like

Would appreciate for Figma to resolve this.

I am publishing updates from a library quite frequently and am having to hack it by right clicking on the design file tab > reload tab every time I am in the design file in order to actually be able to update it.

It is frustrating because it usually starts off working and showing me the ‘Update Instance’ (almost like it has reached a quota… :thinking:), then suddenly stops displaying after I publish the library.

Along with a plethora of other Figma Library issues that are slowing down work efficiency, when it’s all added up takes a fair bit of time to deal with throughout the day.

1 Like

Same issue.
I’ve published a change in the library 15 minutes ago and the notification “Review and accept library updates” is not appearing in the master file. Please fix.

**Edit: Restarting Figma did not help.

I would appreciate if Figma can just respond that this is an issue.

It seems to be getting worse. Now when i publish the new components are not showing up in the shared library. I have to copy and paste from the library and only then will it show up in the design file!!!

Figma, please at least respond!

1 Like

So as I have had this issue on some days and some days not, I personally assume that this might has something to do with Figma’s Server Ressources? I did not change anything on my file and early morning yesterday everything was quite smooth… today during daytime it’s not working properly anymore. Feels just as if the Updates take very long due to maybe heavy traffic on the servers as everything is in the cloud? Would be cool anyway to get some Input by Figma as this thread has thousands of views already! @Figma_Moderation

1 Like

Does Figma support exist?

1 Like