Change To option not working

Hi guys. I have been using Figma for a while now and I just noticed the “Change To” option when prototyping. When I saw it I wanted to use it but it seems to be greyed out and I can’t click it. I searched on YouTube and here but didn’t find anything helpful. I even tried Figma Beta but still nothing. Any suggestions?


Change to is causing some trouble for me now. I have a component for a section of my page made up of various other components (including an instance of a lock icon). I have 3 variants of this page section component and I want to be able to swap between them when I click on the lock icon.

As you can see the change_to option is available to me, but for some reason I’m just not able to toggle any of the properties to actually get it to change.

I’ve tried changing the interaction type to hover, etc. and the behaviour persists
I’ve also tried changing the values of the properties so that I get a dropdown instead of a toggle but although I can open the dropdown and select the value I want, it does not register my selection.
Using Figma in Chrome Version 107.0.5304.110 (Official Build) (arm64)
Have tried using Safari as well (logging in for the first time using Safari) but it’s the same issue.

I was able to get it working, but for some reason I had to add the interaction on Icon SVG layer itself rather than the instance of the icon component (see highlighted layer)


Can confirm I get the same experience as @Conor_Lonergan with regards to the “Change to” being available to select however not actually being able to change any properties whenever I’m applying this to a component.

My example is a Button component inside of a component which has two variants. When I try to make an interaction on that Button component directly so that clicking it switches between the two variants of the new component it’s nested inside of I get the error mentioned. That being I can select the “Change to” however when I actually attempt to change the properties as part of that it won’t let me make any changes (such as select another variant from the dropdown).

In order for it to work, I have to wrap the Button component in a frame/group then apply the transition to that layer instead. This seems like it might be an actual bug since the flow is only broken half way into making the interaction.


I have exactly this problem. I’m trying to prototype a selectable row in the table, so I have a checkbox and on click the row should change between default state and selected state. But I cannot choose the variant for the row component.

This works for me.

hello i have the same problem. i tried to create a variant of the card (to do a simple hovering effect), but ‘change to’ does not activate

1 Like

ps Figma Help Center article, do not explain this case.

Excuse me tank666 I see that you solved and closed, but in what way did you solve?

Thanks in advance

What kind of problem are you facing: as the author of the topic or as other users in this topic?

Please share details about the problem. It would be great if you could send a link to a file or video showing all Figma panels.

I have exactly this problem and no matter what I do, it wouldn’t work. It works for 1 click but it wouldn’t work to change it back between the chosen component. I decided to delete it and it didn’t seem to disappear weirdly, like the function is still there even tho I removed the interaction already.

Same issue. I have a component with two variants, collapsed true and false.

When I added an interaction to a button in the true variant, the prototype > tap > collapse value will only allow itself to be set to true (even though the element I’m adding the interaction to is in the true variant).

When I click the toggle to false, nothing happens, it won’t switch to false. The only way I resolved this was to set the interaction to occur on the text inside of my nested button component. Seems like something that needs to be addressed, it caused me a lot of frustration for no apparent reason.

Same problem… How is this simple issue still not fixed after a year?


Same issue. I’ve a row to collapse a panel. One component, 2 variants. The “Change to” switch is visible but not interactive.

Same issue. Still present.

Can’t switch between 2 variants in one click.

Same problem here

Exactly the same issue here

I’m having the same issue as well. Whenever I try to “Change To” another property, it just doesn’t save my desired option: