[Bug] in spell checking

There is a bug with the new spell checking feature.
In my case the keyboard layout and spell checking is set to German – but when I type e.g. quotes, Figma automatically types “English quotes” instead of „German quotes“. Not sure about other languages (like French or Japanese quotes).

Not sure, but does Figma’s spell checker track quotes? If this is indeed a bug, you will need to submit a bug report to support.

Have you tried unchecking the “Substitute smart quotes” item located in the Main menuPreferences?

1 Like

Ah, good point. I’ll check the quote settings tomorrow morning.
But — shouldn’t smart quotes adopt the language used for the spell checking anyway?

If this is implemented in the Figma code, then yes, they should. But it seems to me that the Figma team did not change the smart quotes feature for spell checking. So this looks like a feature request, not a bug.

Hi there,

I’ve just checked the settings. “Substitute smart quotes” is switched on.
And therefore, it switches e.g. from "" to “”. But in combination with the new spell-checking it’s grammatically wrong, as in e.g. German it has to be „“.
In my opinion this is a bug. I’ll submit a bug report and let’s see what the Figma devs will do.
As always, thanks @tank666 for your reply.

This topic was automatically closed after 30 days. New replies are no longer allowed.