Zooming is not working properly

From past few days, zooming on Figma is very weird. If I dezoom it goes to like “2%” almost immediately and it will go to “2772%” when I zoom back. It’s just not possible currently for me to work with Figma because of this.

Anyone has the same issue ? I checked and there’s no update available. I am on latest MacOS and using the desktop app. I’ve tried reloading tabs, close app, relaunching computer and it doesn’t fixed it.

Please help !

Hey @Quentin_Nolan ,
Sorry to hear you are having issue with zooming! Does the issue happen in both the browser and the desktop app?

Can you confirm what method you are using for Zooming when this gets stuck? For example:

  • Pinch to zoom on trackpad
  • using command + the mouse wheel to scroll
  • the zoom button in Figma

It seems you may be running into an issue with pinch to zoom on MacOS that our engineers are aware of and believe should be resolved on OS 13.3 and above. Where possible, we ask that you update to MacOS 13.3. If this does not help though, we’d appreciate if you could confirm your OS version, your device model and let us know whether the issue persists on other surfaces (e.g. Google Maps).

While there isn’t one clear workaround we can suggest, some other things that have helped users include:

  1. Going to “System Preferences” → “Accessibility” → “Pointer Control” → unchecking “Ignore built-in trackpad when mouse or wireless trackpad is present”. If it’s unchecked, toggle it on and off.
  2. Deleting your Property List (PLIST) files. MacOS uses PLIST files to store a user’s settings and information about bundles and applications installed on a machine. Deleting them will force your Mac to recreate new ones.

To delete the PLIST files linked to your mouse and trackpad, open Finder then click Go > Go to Folder . Next, type /Library/Preferences and hit Go .
Look for the following plist files, delete them and restart your computer:

  • com.apple.driver.AppleBluetoothMultitouch.trackpad.plist (Magic Trackpad)
  • com.apple.driver.AppleBluetoothMultitouch.mouse.plist (Magic Mouse)
  • com.apple.driver.AppleHIDMouse.plist (wired USB mouse)
  • com.apple.AppleMultitouchTrackpad.plist
  • com.apple.preference.trackpad.plist

If this still doesn’t help, please reach out to the support team so we can investigate it further: here