Why don't Figma links open in the App? Why do they open in the browser?

Figma links should open in the App. Stop cluttering my tabs. It’s bad enough to have to have the Figma forum open for all the things wrong about this app.

1 Like

Hi @jamiegraydesign ,
By default, when you click on a Figma link, Figma will open the link in the browser.

If you want to open all Figma URLs in the desktop app, you can enable the Open links in desktop app setting. You can find this in your Preferences .

Please remind you can only access this setting if:

  • You have the desktop app installed
  • You are using the browser version of Figma. This setting isn’t available in the desktop app.
  1. Open the Capture d’écran 2023-09-14 à 11.59.21 menu and hover over the Preferences option.
  2. Select the Open links in desktop app setting.
  3. A checkmark will be displayed next to the setting to show it is enabled. If there is a check next to the the setting already, you can select the setting again to disable it.

Hope it helps!

1 Like

the setting is removed in version 116.15.4.

1 Like

Can confirm, this setting no longer exists in the current version when opening a Figma link. This issue seems to have been plaguing Figma users for quite some time. Any definitive solutions in near future?

1 Like

Similar issue here - the option to enable opening in app appears under Preferences, but does nothing when checked. I’m logged in, but the option to open in desktop app doesn’t show, instead it has “Get desktop app”.

I am also having this issue, but with Figma not opening the mobile app on iPhone. Is there a workaround specifically for mobile?

@Carl_Antone the option can only be found when opening a design file on the browser. It’s not available on the desktop app.

This is a stupid solve. All of us have to share prototypes with people that don’t use Figma often – thus don’t have the native Figma app – AND people that do. The control should be at the Copy Link level.

The fact that you can only set this when a Design file is OPEN, does not help if anyone is having issues with WebGL or getting files to open in the desktop. Why is this not a setting in the desktop app itself? It’s infuriating.

1 Like

This is exactly my situation.

Here isn’t a system-wide setting to prevent links from opening apps on iPhones, but there are a few effective workarounds:-

Long press the link:-

  1. This is the simplest and most common method. Find the link you want to open in Safari or another browser.
  2. Instead of tapping it, press and hold on the link for a second or two. This will bring up a context menu.
  3. In the menu, tap “Open” or “Open in New Tab” to open the link directly in Safari, bypassing the app.

Use Guided Access:-

  1. Guided Access is an accessibility feature that lets you lock your iPhone to a specific app. This can be useful to prevent Safari from opening links in other apps.
  2. Go to Settings > Accessibility > Guided Access.
  3. Turn on Guided Access.
  4. Open Safari and navigate to the link you want to open.
  5. Triple-click the side button (or home button on older iPhones) to activate Guided Access.
  6. You can now browse Safari without it trying to open links in other apps. To exit Guided Access, triple-click the side/home button again and enter your passcode.

More effective solution below