Two factor auth not sending the SMS message

It seems like there’s a bug in the two factor auth functionality, I’m not getting the SMS message on my phone, it does not work from the browser, neither from the macOs app, and I can’t even get to this setting from the android app to try it out from there as the “general” button on the settings does not take me anywhere.

This is particularly troublesome as I’m trying to get a Plugin published :sweat_smile:

Anyhow, thanks for making ALL of the rest of the features be awesome and work well! :muscle:

I forgot to attach the screenshot of where I’m stuck, not very useful anyway.

I also would like to mention I attempted this YESTERDAY several times and I’ve not received a single message yet, so it’s certainly not a bug in my patience haha.

Hey Ignacio!
Sorry to hear you are having issues to log in! The solution here would be to remove the 2FA setting. To protect your privacy, it’s best if you can change the account settings on your end. Many users are able to self-resolve this issue by trying the following:

Check all browsers and apps used to see if you’re still logged into Figma:

  • If you’re still logged in, you can remove 2FA settings from your Figma account settings. Please scroll down to the “Remove two-factor authentication” section in our article: Enable two-factor authentication (2FA).

If you can log in with Google:

  • You can sign in with Google to bypass the 2FA process. Please go to https://www.figma.com/login and select the “Continue with Google” option.

Your account’s 2FA code is generated by an app:

  • The apps you might used to set up 2FA could be: Google Authenticator, Duo Mobile, Authy, or 2FA. You can read more about this option in Enable two-factor authentication (2FA). If you haven’t already, please make sure your 2FA app is installed and up to date. If you have trouble installing the app or accessing the authentication code on your app, please reach out to that app’s Support team.

If these options don’t work, please let us know. You can request that Figma Support removes 2FA from your account manually through our identity verification process by reaching out to the support team (and please recall the steps you have done): here

Hope this helps!

I just tried this by logging in trough google instead of my account, it’s still asking for the SMS code when I get there. Just to clarify, I don’t have 2FA enabled YET this problems is occuring when trying to do so, seems like I don’t have the option to use an auth app instead of SMS in my case.

Ah thanks for the clarification! This is odd that it doesn’t work with Google.
Not sure where the issue may come from :thinking: Please reach out directly to the support team, they can investigate further here: https://help.figma.com/hc/en-us/requests/new (via the form, please recall the steps you have done, and be sure to use your Figma account email, thank you)