The 'change to' button greyed out

My ‘change to’ button is greyed out even though it is available for everyone to use now. I have attached the screenshot as well.

Hi Palak Rai, can show more screen shot on right side panel?

Hi @Palak_Rai ,

Perhaps because you are not in a variant on the same component-set ?

https://help.figma.com/hc/en-us/articles/360061175334-Create-interactive-components-with-variants#:~:text=When%20you%20add%20an%20interaction,interaction%20when%20building%20your%20prototype.

image


Uploading: Screenshot 2022-06-03 at 7.57.51 PM.png…
Hi, here you go. I started only 2 months ago. Therefore, can u explain the variant part to me a little elaborately? I think I have put all the elements into one component and then tried to use the change to option.

Hi, i think i have put the variants in the same component set. here is the screenshot. please help.

Can you share a link to the Figma file? I think it’ll be easier to figure out what’s going on that way.

1 Like

https://www.figma.com/file/An7B0KeTK16bqBduM2Zkoc/Madhur-Armchair?node-id=144%3A2283 @RizePoint_Product there you go!

It looks like you created them as a single component instead of component set.

2 Likes

@Palak_Rai From the screenshot alone I’d say that what @experiment said was correct. I just went into the file and everything in your screenshot is inside the same component. What you want to do is breakdown this master component into multiple variants of the same component. And then the Change to will be available again.

What @experiment and @Vinicius_Blembeel said. Create a master “Carousel” component , then duplicate that component 4 times (making any changes to each as necessary), THEN create a component set from those 4 duplicates. The “Change To” option will be available on the component set at that point.

1 Like

I put together a quick demo to show what we’re talking about