Text missing in preview but displays fine in present mode


I have created an accordion component, when I preview it some parts go missing and the content moves around. When I open it in present mode it works and looks completely normal.

Any ideas? I’ve tried rebuilding the component, different content etc. but all seem to end up broken. Looks like when sharing the link out, that it uses the preview mode so is broken to everyone that views the file.

Link: https://www.figma.com/file/GyXkrlIPY6rybN8MtMOYmX/Untitled?type=design&node-id=0%3A1&mode=design&t=RjlqHpgh8anY6erX-1

Here’s how it looks inside of Figma:

Hi Toby!
Sorry to hear you are having issue with the preview mode. I tried to replicate on my end, and it seems to work fine both preview and present mode. (Please check the videos below, in case I miss something.)

Can you share a quick video recording when you try to see in preview mode?
As a workaround, I’d recommend you to clear out your cache:


Use the Terminal app to clear the cache.

  1. Quit the Figma desktop app.
  2. Open the Terminal.app and enter the following command: rm -rf "$HOME/Library/Application Support/Figma/"{Desktop,DesktopProfile}
  3. Try opening the Figma desktop app again.


Run a command line from the Start menu.

  1. Close the Figma desktop app.
  2. Open the Start menu and paste the %APPDATA%\\Figma command. Press the Enter key to submit.
  3. In the window, delete the DesktopProfile folder.
  4. Launch the Figma desktop app again.

And force-quit the Figma Desktop app and restart it (or force-quit and open Figma in a new browser window) to see if that helps. Hope this works!


Thanks for the reply!

So there should actually be content within the first two, which looking at your screen recordings isn’t displaying, this is the issue I am facing.

This is how it looks in present mode for me when I open them:

But I get the same issue as you when I try and preview where the first two don’t display any content below them.

I have tried clearing cache etc and accessing via a private browser window but still no luck.

Any ideas? Thanks.

Ohh thank you for the clarification! This looks odd. Hmm not sure where the issue may come from, I tried again with another font as I don’t have your current font (I have missing fonts on my end), and it seems to work now when I refresh the tab.

Can you please try to replace another font, and apply once again your initial font to see if there is any improvements?
I’d suggest you to reach out directly to the support team here with a copy of your file: here Our technical team can have a deeper look at it!
Be sure to use the email associated with your Figma account, a link to the file, and share the file with support-share@figma.com (with edit access), this won’t affect your billing at all. Thank you, and sorry again for the issue.