Suspected min width bug

When I change a variant on a component (a text field), that is placed within another “main component”, the min width value that is set for that text field in the “main component” disappears.

This only happens in the instance of the “main component”.

Is this a bug?

Hi @Fernando11 I tried this from my end but it seems to keep the min width of that nested variant. Can you try clearing your browser or desktop cache and see i this helps improve anything.

If it doesn’t, mind reaching out to the support team directly via this form for help:

Be sure to share a video of the issue you are seeing, include a link to a demo file, and share it with so they can take a closer look.

I’ve seem to figured out where it buggs out for me at least:

I put two text fields next to each other with auto layout (these are components from a design system file).

I apply min width to each of them and then wrap the auto layout so that they align vertically when resized horizontally. I create a new component of this. The instance works, no problems.

Until, I take two instances and put them together to create a new component. The instance of this new component is where min width disappears on the text field when I change a variant.

The min width seems to disappear when the text field is edited when being nested three times (if that makes sence)?

I tried to upload a video but could, something about not being a member.

I’ve solved this issue by building my components without so many sub-components.