Strange new scrolling behaviour

So I noticed that there is a strange scrolling behaviour now, that screens by default are not set to no scrolling anymore and elements placed on screens are not fixed. This is very frustrating and results in having to go into each screen and setting individual elements to fixed.
What is happening here? Does anyone know how to amend?

Hey there,

Thanks for flagging. Though I am probably misunderstanding and I tried to reproduce on my end, but it seems I’d need more information to do the same. Would you be able to share the screen recording that you’re experiencing? Or if by any chance, do you know if this is happening to your colleagues as well? I hope I can investigate more.

Thanks,
Toku

Hi there.
Yes, my prototypes are always by default set to scrolling and most of the time that is super invasive and difficult to work with. Here is an example where I for example cant even turn the scrolling off. Super weird. Results in me not being able to preview the design properly. Ive been using Figma every day since 2021 and never experienced such issues. I hope now that Adobe is in the picture they wont shipwreck the UX as with their own apps.

Hi @N118

It appears that the block you selected (on your screenshot) is contained in an auto-layout. Auto-layout arrange children according to each others. One element, by default, cannot behave differently than the other.
You may enable “Fixed (stay in place)” by :

  • removing the auto layout on the parent
  • applying an absolute-position to the element your want to be fixed

From my point of view Figma is trying to get closer with app development by mimicking their constraint. And it’s a pretty common thing to make content scroll when it overflow the page size (default behavior in web development for example).

Hope this helped

1 Like

I’m having similar strange behaviors regarding this as well. I spent quite a bit of time doing trial and error with absolute positioning and the scrolling/no scroll/sticky settings, and just can’t get to what I want, which is pretty simple really: I’d like to designate specific frames not to scroll.

@N118 Have you figured this out?

Also, separate but related issue: I have a two-column auto-layout frame, with a tabbed panel in the left column, and a data table in the right column (a pretty common UI layout). I’d like the tabbed panel to stay put (not scroll), while the data table in the right column to scroll. I can’t get this to work either.

Has anyone figured out how this is supposed to work?