Stop downsizing images Figma!

Figma downgrading image resolution for images larger than 4026px in either dimension is terrible and seemingly arbitrary.

WHY this size?
WHY have a limit this low?

When designing for web especially, most screens are beyond this limit in length but there may be a particular background we want to try out, or importing full page screenshots of a site to use for examples, or even a project we’re working on.

Currently I need to make a quick prototype of a project I did years ago before Figma existed so the best way to import the screens is from png’s exported from InDesign but everything is super pixelated when importing into Figma even at 1x size


Hey @MattBraun,

Sorry for the frustration! Figma only downloads high quality versions of images in your current viewport. For images outside your current view, Figma will load a lower quality version. This is meant to improve performance when you first load a file.

If you have a lot of high-resolution images, your images may look blurry at first, but Figma will continue to load high-resolution images as you explore the file.

More info here:

This isn’t true, at all. I understand using downsized versions for quicker viewing, especially if using Figma in a web browser. However, for working on files in the local app the severe pixelation isn’t just when viewing, this is just the version we’re stuck with. I could understand a little downsizing the way programs like Illustrator and InDesign do but they’ll still export just fine unlike Figma which exports these pixelated images as pixelated images.

Image downsizing at this extremely conservative size should only be an option, possibly a limit on the web version. Consider newer high-res screens that we’re designing for such as iMac…4026px limit just doesn’t cut it! Even my 2yr old macbook air is 1920px wide!

example below…
portion of actual screenshot compared to how it looks imported/exported in Figma (at only 1/3 original width…this should only happen if I scale up beyond the original width)


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.