Spell Check?

I can’t get spell check to recommend the correction of a red-lined misspelling. I’ve read all the articles I could find and haven’t been able to solve this.

Spell Check is activated and I have chosen my language, English.

Hey there, thanks for reaching out and sorry to hear you’re having trouble witk spell check!

Is this happening both in browser and using the desktop app? What troubleshooting steps have you tried so far?

  • logging out and back in
  • clearing your browser/desktop app’s cache
  • un-installing and re-installing the desktop app

Here’s how to clear the desktop app cache on a Mac:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf “$HOME/Library/Application Support/Figma/”{Desktop,DesktopProfile}
  3. Try opening the desktop app again

Here’s how to clear the desktop app cache on Windows:

  1. Close the Figma desktop app
  2. Open the Start menu, and paste in this, followed by enter: %APPDATA%\Figma
  3. In the window that opens, delete the Desktop and DesktopProfile folders if they exist
  4. Launch the desktop app again

I’m having this issue also, I’ve try the mac app fix suggested but no change. There are no correction options provide for misspelt words. Mac desktop app 124.0.2 on Sonoma 14.4

Hey @Wayne_Murphy ,
Thanks for flagging it, this seems odd!

As a reminder, the spellcheck language and settings are based on your device’s settings. (please check the language)

There are some differences depending on the operating system you are using:

On Mac: Figma auto-detects and uses your system’s preferred language for spell check
On Windows: If you don’t see the language you want to use, you may need to install a language pack (more detailed instructions on that here).

If the issue still persists, I recommend you to reach out to the support team, and please mention the steps you have done so they can investigate it further: here