Setting to turn off automated lists

I think this workaround is simpler:

1 Like

In Danish we write dates like this:

  1. januar = January 1
  2. juni = june 30

I am currently designing a bank app with A LOT of “first of the month” dates … and every single time it converts the date into a list. I am going insane about this.

3 Likes

Lol … same problem here it seems … I wrote 30. juni and it autocorrected it to 2.

Yeah. Um. I’m really growing tired of the over auto-this, and auto-that we seem to be baking into our apps. This era of “predictivity” is starting to interfere with being able to work efficiently; not to mention a form of crowd control which goes against the very nature of creativity. I can’t believe Figma just assumed everybody would need/want to detect a 1. as a bullet and auto format! This predictive feature is more annoying and time consuming than it is helpful.

1 Like

I think turning auto format on / of would fit nicely into this little preference menu:

Although I find it mostly useful. If I really struggle with something like writing dates, I add some special character in front (eg. writing “+1. January”) and when I’m done with all entries I remove the special chars with some plugin like “change text”. Also just hitting CMD+Z is not the worst experience…

3 Likes

Please, Figma team, add the option to toggle auto formatting on/off! It’s a nightmare when writing dates, especially in languages like Czech or Slovak where we write dates with periods and use spaces between D and M (= 24. 12. 2023). Please!

2 Likes

It is also a nightmare when you type “!=” and get “≠”. And there’s no Cmd + Z for it!
It’s a Python snapshot, seems like Figma thinks it knows better, but it really doesn’t.

Please, turn or rip off this feature forever

Also double dash that turns into “—” makes a lot of trouble for me

This is not a replacement, this is a ligature in the font YOU chose to use. You can turn off ligatures here:

Or change the font. You are cursing font designers now for no reason, Figma has nothing to do with this.

2 Likes

Thank you!
I must say sorry to Figma guys

This is still seriously needed!

In nearly every website design I create I have headings that include dashes, especially on line start. There is simply no way to do this in Figma without extreme hassle.

If i let Figma auto-create the list and then remove the list style, it removes the dash as well. If I try to add another dash and space after the list got auto-formatted, it directly deletes the second dash which is horribly frustrating.

I have to type something else, then enter the das and space, select and copy it, move to the line start and paste it there again. But then, as soon as I accidentally remove the space to the beginning, the whole game starts again.

The Cmd/Ctrl+Z option doesn’t really work either, because Figma seems to apply some sort of styling to the dash that then overwrites the text style that is applied to the text field. Which is also frustrating because then you also have to select the dash and re-apply the text style (selecting the whole field often doesn’t work if there are multiple text styles in the field (e.g. some other type for highlighting).

This is a thing that I encounter nearly every single day and it’s causing me more than just a few grey hairs… it’s such a simple thing but it’s so frustrating and a constant problem that I have to think about switching toolsets just to not go insane at some point.

2 Likes

I wouldn’t call this solved at all. Yes, I can use extra clicks undo the mess that Figma adds but it is constantly in the way. I posted the original comment over 2 years ago and this is still a daily frustration.

Agreed, this is just a temporary workaround. Figma should not be automatically formatting any kind of text.

To be frank, the fact that turning off the automatic conversion or being able to toggle a list after the fact is NOT possible is mindblowing to me. This isn’t a feature request, it’s a bug report.

This feature is probably the most annoying Figma feature to me.
Please add a setting somewhere to disable this.

This is ridiculous. In this case, Figma acts like MS Word, not a design software. I need to use “1. xxx” in a title, I had to split it into two layers…

1 Like

I ran into an issue with this too. When I try to copy the numbered lists to something outside of Figma, then it removes the numbers! Please fix this!

Please also remove using * as creating automated bullet point or provide ability to turn off this in user preferences.

Super annoying when I just want to get a bunch of spaced out bullet symbols in a row. Turning the list formatting off and then trying to insert a space break after a bullet symbol triggers the auto-list back on again and for some reason deletes the previous bullet already typed in.

Super mega uber annoying. Please give us a setting to turn auto-formatting off.

1 Like