"See all layers" - not showing deep selection

It seems there’s a newish “feature” in the layers panel that collapses layers and has a ‘see all layers’ label. the problem with this is that when i deep select a layer (i.e. ctrl/cmd + click), it does not automatically go to that layer in the panel. instead it remains hidden under that collapsed state. super annoying!

please fix this that so that it automatically exposes the layer in the panel when selected. also, there should be an option to turn this feature off, as it’s rather opinionated and not in a good way.

image

Thanks for the tip, but my gripe was more that clicking into a nested layer should still expose it. That is independent of turning the feature on or off. As for turning it off, often times in larger companies you don’t have edit permissions to the file with components, so your only other option would be to break the component which isn’t good either.