Prototypes work only 1 time - then break

After setting up my prototype, I click the frame to test within my Android tablet’s Figma mirror app and the prototype works as expected. However, when I navigate back to the same frame later in my Flow, the prototype no longer works. I’m experiencing this within the desktop app as well.

Has anyone experienced this or know what I’m doing wrong?

So far, I’ve tried:

  1. disconnecting all other prototypes on the frame to ensure there are no other prototypes.
  2. disconnecting the components that were tied to copied frames.
  3. overlaying the components I want to navigate with a top layer
  4. disconnecting and reconnecting the prototype
  5. I’ve tried connecting to various aspects of the components

None of the above seems to fix the issue. Every time I update the prototype it works the 1 time and then breaks after that. I’m experiencing this on multiple frames that were copied from earlier projects.

1 Like

I was able to fix the problem.

For those that this may happen with. I was copying frames and did not realize that I copied and pasted a frame over the previous frame, but did not move the duplicated frame.

Thus, the prototype was sending me to the original frame. After deleting the top frames, everything is working as expected.