Prototype mirror doesnt show images

Hi y’all,

I am experiencing some issues with the Figma mirror app. It will not show images in the prototype.


  • M2 mac, Sonoma
  • Figma desktop app
  • Figma mirror app iphone

Troubleshooting I tried

  • Delete cache, didnt work
  • Constrains of the images
  • Reboot apps
  • Check if the images are IN the frame

I drives me crazy, maybe because the Sonoma update? I worked before.

Thanks in advance :slight_smile:


1 Like

I have the same problem since this morning

Exactly the same here, except Monterey.

Hey all, thank you for flagging this! Our engineers are investigating this issue currently, and we apologize for the inconvenience.


the same here, come on please

It is working again for me, thanks!

I’m experiencing the same issue since this morning: the prototypes aren’t displaying any images.

I had a usability testing session scheduled for today, it’s frustrating…

1 Like

I’ve been having the same problem since this morning, it still doesn’t show images…

Same issue

Same issue here.

My prototype contains a lot of images and most of the images (90%-ish) are not loaded when I open it from the mobile app/web prototype, all vector/text elements appear perfectly, the only issue is the image load. But when I open the prototype from desktop app/web it appears perfectly fine.

I have checked the discussion on this thread Photos do not appear when Playing prototype but it doesn’t solve my problem, please help.

Even I’m facing this issue since this morning

Same here since this morning :frowning:

It’s working for me, thanks !

Hi everyone, thank you for the report. This issue has been resolved and services have been restored across the board.

1 Like

@Ryan_52 thank you for the quick update! It is working again here. Kudos for the devs picking it up so fast :wink:

1 Like

Today again on Mac OS 14