Prototype doesn't load anymore, after the latest update


I’m unable to launch the “Present” mode anymore with my bigger files. This happened today, immediately after I updated Figma.

It just hangs in the loading stage with the progress bar stuck.

I can “Present” smaller files though, so this must be memory related issue that surfaced after the latest update?


Same here, on both desktop and browser versions.

If the prototype happens to open, it ultimately hangs completely :woozy_face: A very variable-heavy prototype so not sure if I’m just hitting some limits here.

1 Like

Thanks for confirming this @erasku !

Let’s see if more complaints appear. In mean time I suppose only thing left is to optimize the component variants and divide prototype to even more files.

1 Like

Same. Prototypes rendered completely unusable by this latest update.

Hi, I’m also having problems with the prototypes. The links seem to be broken, they redirect to the wrong screen rather than to where I’m linking. I also updated today.

1 Like

Same. Hotspots just not working, despite being configured correctly.

Hey all, this sounds pretty serious. If you are experiencing issues with a prototype and are willing to share the underlying file with us, can you DM me the link and invite via the share panel? This will help us get to the bottom of things quicker. Thanks!

For issues with hotspots not working or linking to the wrong screen, it’s also really valuable to include info about the buggy hotspot (e.g. what’s expected and what actually happens when interacting with it). A few sentences or even screenshots/video helps a lot, especially in large prototypes. You can share this with us via DMing or emailing (and linking this thread so the ticket gets escalated).

Thanks @Andrew_Chan !

My original loading problem has been resolved on it’s own. Prototypes are loading as they should. Perhaps it was just a connection issue, originating from Finland as @erasku also experienced this.

Yeah, I can confirm that it has been miraculously fixed. I can recall having some auto-save issues as well so it might be this was a server-side issue.

Having the same issues (apparently). Im trying to share a prototype for presentation and the person keeps reporting back that it just hangs on the loading screen and never gets them in.

I should mention also that it is an inherently large file, full of images (ex. exporting as a PDF yields a whopping 113 MB file).

That said, it loads in every browser of mine, incognito or not, but the person I’m trying to send it to is consistently met with the loading bar which freezes at the very end.

Hey @Andrew_Chan i commented below as well. I shared my file per the instructions. Will wait to hear from you!

I’m having the same issue! When I try to open prototype links in the browser, nothing loads and the screen is blank. At the same time, the prototype becomes blank in my figma app. Please fix!

This same exact thing is happening to me too. The prototype will load in the browser for some people, but for others (including myself) it just stays on the loading bar or goes blank (happening in both Chrome and Safari). And when it either gets stuck loading or goes blank in the browser, the prototype screen also goes blank in my Figma app. Please help quickly! There are many stakeholders who are currently not able to view my projects.

1 Like

Same with me. Sometimes the prototypes will start with a loading bar but get stuck. That makes the tool basically useless to me… I don’t really want to go back to PDF export…

Same here. I’m trying to load a simple 9-page prototype, but it just hangs on the loading screen forever. I’m using the Mac desktop app with the latest version. I even tried duplicating my file and removing all the pages except the one I am trying to view. Still wont open present mode.

I’m on a Mac and can’t load prototypes in Chrome. They open in Safari.

I am also experiencing this issue. Is there any way to fix this?

Thank you.

Having the same issue. Here’s what I tried:

  • Prototypes work fine in Safari
  • They work fine in Chrome Incognito mode

But not in normal Chrome.