Presentation issues: Not showing icons and interactions not working properly (Beta version 124.1.1)

After the recent update (I’m using beta version 124.1.1), some assets take too long to show when presenting a prototype. The same issue occurs on the stable version (not beta).

I have this component with an icon and a label. On the prototype file they appear ok:
image

But when presenting, the same icons don’t load. Some have a light-grey box instead.
image

image

The same component has interaction state, and they are also not working.
The click works and opens what it is supposed to open, but the appearance does not change.

Tried reloading, clearing the cache and logging in again. Nothing works.

The presentation page had to be opened for over 5 minutes, and if I reload the file, it resets, and the presentation needs another 5 minutes to load the icon.

I also tried looking for similar posts about this recently and couldn’t find.

Hey there!

Thanks for the post. The beta version of the desktop app is a test environment. If you notice issues or behaviors that need our attention, please submit a bug report. Switch to the regular version of the desktop app if needed.

Thanks!
Toku