My color variables are hidden at publish!

Somehow my color variables are hidden in the publish, i’ve checked and they have the hidden checkbox unchecked so i dont understand why this is happenig!

image

1 Like

Hi @Bruno_Justa, Thanks for reaching out about this.

Can you please double-check the setting of “Hide from publishing” for your variable collection [Colors]?

When you hover over a variable’s row, you should see an ‘Edit variable’ icon. Clicking this will open the Edit variable modal. In this modal, please make sure that the “Hide from publishing” option is unchecked for each variable.

If you’ve confirmed the above and the collection still appears under the hidden section in the publishing menu, could you please try the followings to unhide the collections :

  1. Open the local variables modal
  2. Edit the name of the collection (e.g. add another letter at the end of the name)
  3. Undo the change

Please check to see if that collection is now no longer hidden in the publishing menu.

Hope it helps! Please let us know if I overlooked anything.

Thanks,

I know that for components, you can quickly designate one to be hidden by beginning the component’s name with an underscore, like ‘_componentname’. I wonder if this could apply to variables too, are any of your variables in this format?