Masks breaking when exporting SVG

I’m trying to export an SVG as a cloud with text in it, but when importing into another program, it ignores the cloud mask. I’ve searched through many posts on here but I don’t see any solution specific to this issue. Here are some details:

  1. Type a wall of text
  2. Use cloud shape as mask
  3. It looks right in Figma, exports incorrectly

Hi there,

Thank you for getting in touch. Could I kindly ask you to share the program you referenced in your message? Additionally, if possible, could you also provide the exported SVG file for us to review?

I tried to check an exported SVG on the browser, it worked fine. I’m wondering why it is happening!
image

Thanks,
Toku

I was able to narrow it down. The program I was trying to import into is Xtool Creative Space (for a laser cutting machine) and it just doesn’t handle the SVG import correctly. Here is the file that works in the browser.

It won’t let me upload an SVG here, but I made a Google Drive link for it: Nursery Cloud test.svg - Google Drive

Thanks for sharing the helpful details! If you have any further questions, please feel free to post.

Thanks,
Toku