Make Version History links work again

In 2019, Figma released a feature that allowed users to copy the link of a history version of a design file and share it with others. However, it seems like the link is not working now? I’m only able to link to the page, but not the exact version of the file…Anyone else experiencing this issue?

1 Like

It never really worked. :smiley: It should work for editors of the file. And there is not much point in sending it to viewers, you can’t achieve a “frozen” version of the file this way.

Hi, If I understand you correctly when you link to a specific version it opens the needed page but the current version of it, not the previous one. Right? I experience the same problem.
I was inspired by Archiving pages in a file - YouTube and tried to reuse such approach but links don’t work. And as I see in the comments other people have the same problem and 4 months ago @Rogie_King replied that the Figma team is aware of this problem.
Curious to know if they’re going to fix this :thinking:

It’s not working for me, and I’m the file’s creator. No matter what version link I grab, it only opens the current version. I even tried opening the link on another computer in case it was an issue with browser or app caching, and it’s the same thing; it only opens the current version.

This issue still presists. Tested today.

Versioning is completely useless without the archived links working.

According to the release notes and announcements from 2019 this should be working and still is not - can anyone possibly provide an update on this broken feature? It seems to me teams should steer clear of using versioning at all until this is resolved.

2 Likes

I saw this working once. What gives??

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

I’m trying to create a release note page inside a figma design file. This page contains the file thumbnail and links to previous iterations, change notes etc,

When I’m including a history link of a previous version of the same file, the url doesn’t work properly, instead of opening the historic state, it just opens the latest version.

The link is correct, if opened outside figma it will go to the right history version, but if it’s opened from the figma file it will just leads to the most recent version of a particular artboard.

As results users might confuse the changes to the design and might not be able to determine something new from something delivered. It also affects trust, my organisation needs to trust that figma is storing our files correctly. If we can’t trust that then it’s game over.

Anyone experienced this issue before?

Cris

I have the same thing, I have a release notes artboard with a link to a previous version but it only opens the current version. What’s the point of having the feature of copying a link if it doesn’t work? This technique with linking to an old version was shown in one the Figma sessions/tutorials on Youtube but it doesn’t work.

I have a link to a previous version of the same file, within that file. The first page is a sort of versions list, that links to previous versions of the file.

When you click on the link from the Mac app, it does nothing. If you copy and paste that link on the browser (and choose to open on the browser), it works.

This seems to be a bug to me. Do you have any recommendations on how to work around this?

1 Like

Any update on the status of this bug?