Keep interactive component state between frames (5 stars rating)

Hello,
Right below are my examples. I’m trying to 2-steps rating interface.

Page 1 : I click on stars for a global note (3 stars in my video example)
Page 2 : It opens new frame by keeping my first global note I click on Page 1 (So 3 stars

How to do so ?

Here my video :

Here my Interactive Components for stars :

Make sure that in the list of actions “Change to” is the first action and “Navigate to” is the second action. Also make sure that the component instance names match each other in the two screen frames. Also check the interaction details to ensure that the “Reset component state” option is unchecked.

Hello @tank666 , thank you for your answer. I’ve already did what you said, but I tried it again and it still doesn’t work. Any other suggestion?



Could you share a link to a copy of the file?

Hello @tank666 , sorry for the delay, it was National Week-End here in France.

Here is the file as it is : https://www.figma.com/file/w3HVVAlyJAqHKccKk24BCH/Community?type=design&node-id=0%3A1&mode=design&t=L17r8twmMWtZvfQU-1

I let some interactive components “Title rating” I created to have the result I expect. You can modify anything, I have a copy of this.
Thank you so much.

This is due to the mismatch of layer names between your screens.

I changed the name of your nested frame in the “Screen / Timeline / Rating” screen to the same name of the nested frame as in the “Screen / Timeline / Berlin” screen.

So nice. Thank you :ok_hand:

Hello @tank666 , I’m coming back to you because I had the same problem and here I think that everything matches :
https://www.figma.com/file/w3HVVAlyJAqHKccKk24BCH/Community?type=design&node-id=202%3A11474&mode=design&t=c5F65tXG1HGuIOhy-1

Can you help me with the components in the right side “Meeting” ?

Best,

Your screens “Screen / Timeline / Stay or Go” and “Screen / Stay or Go / Advanced” have different structures. I fixed this, bringing it to a single structure, and in addition, I checked the “Animate matching layers” option in the interaction details for correct animation.

Thank you again @tank666 it works!

By the way, I never use “Animate matching layers” option because I don’t know what it is, and I feel like I don’t need it to make my animations work. Can you explain me in few words?

The Help Center documentation can handle this better: