Keep frames align to top in Presentation mode

Hello there, I’ve been trying the prototype features.
When switching from one frame to another with smaller height, it aligns the smaller one to the center of the screen. There should be a way to set the prototype positioning.
I would like to align all my frames to the absolute top.

3 Likes

Hey @jalbuquerque can you share some screenshots on what you’re experiencing?
Or a link to the prototype?

Also, you can use anchors to align positioning on prototypes but, the prototype needs to be set as a fixed size for that to happen. That can be done under the prototype tab when nothing is selected on the canvas.

I made an example.

When no frame is selected we should be able to globally set the frame alignment to the “prototype browser”.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

forum . figma . com/t/keep-frames-align-to-top/5258

This thread explains it perfectly – it’s frustrating when switching between pages which are designed to be 100% width / height (no scroll) and longer, scrolling pages.

Would it be possible to have an option where prototype mode anchors shorter pages to the top of the window? Its jarring to have them jump around.

5 Likes

Please! This would be super useful.

This is one thing I am seriously missing about Adobe XD… In XD my prototype presentations looked like a fully functional web app. In XD your prototypes align top and fill the width, so if your browser window is sized to match your design aspect ratio, you can’t tell it’s a prototype at all… Please make this possible Figma :wink:

2 Likes

Any feedback on how to fix this?

Is there not a way to do this? It is confusing to present flows when everything anchors to the center…makes it look like modals or pop-ups or something when just going through flows with varied page heights. I am surprised this was designed to default to this mode of presentation and I can’t find a way to present it to model the actual UX.

Have you tried setting your page or content frame Constraints/Resizing to Top only (rather than Top & Bottom) … that seemed to fix it for me.