"Go to main component" doesn't focus correctly


Since a few days, when going to main component in library, it shows me the good page, but focus is not set on the selected component. Is it a bug? something mine?
Thanks in advance!


I was wondering the same thing! Would be great to hear from someone @ Figma

(btw it still works okay in dev mode panel)

+1 I have same issue since yesterday

Also have this issue. The zoom is not focussing on the component.

Hi everyone, thanks for raising this. Are you seeing this issue in the desktop application or in the browser? Mind sharing a short video?

This issue is also happened to my desktop application.

FYI, it can focus on the right main component, but lost the location auto track.

Hello Ryan,

In my case, it’s also in desktop app, and as Jennifer_Lyle and Yulin_H said, focus is working, but zoom on component is not. (sorry i wasn’t precise in my original message)

Video 1: In this case, instance and main component are in different files (library is linked in the instance file) and it fails.

Video 2: the instance is in the library itself and it works

Hope it can help. Thanks!

yep… also getting this. its REALLY annoying!! it takes me to the page but doesn’t take me to the actual component so I have to zoom in and find it. :frowning:

1 Like

It’s a bug, happened after the update of a couple of weeks back. Figured it would be obvious and figure itself out, but it seems to still be there.

I have the same issue, hope this gets fixed sooner than later! :ok_hand:t2:

Also seeing this issue on Desktop (mac). If ‘Go to main component’ still selects the right layer for you, pressing 2 will focus to the current selection (which is the workaround I’m using for now)

1 Like

I think this is because although it is the same library, the parent components are not in the file you are working on (so yeah its a bug).

It seems as though when you are working in the same file where the parent components were created and you click on “Go to main component”, it goes directly to the correct component, however if you are working on a different but the same library of components file it just goes to the correct page where the component is, but not highlighting it!

when I click on the button, it redirect me to the file where there is the particular librairy but it doesnt center the screen according the selected component, we have to find it by ourselves, can you guys fix this? thank you so much !


I am having the same issue since a week or so.

Same issue here, and it seems like links to selection are also having the same issue

Hey @Dragihop, thanks for flagging this!

We’ve merged your topic with another one tracking the same bug. We can see that you’ve also reached out to our support team directly on ticket #820090. Can you please reply to their most recent message?

Be sure to share a full screen recording, if possible, include a link to the file, and share it with support-share@figma.com so they can take a closer look.

I’ve also been having this issue for the last week

Hi Daniel, sorry to hear you’re also having this issue!

You can submit a bug report to our support team directly via the form here: https://help.figma.com/hc/en-us/requests/new?ticket_form_id=360001744374

Be sure to use your Figma account email, include a screen recording/link to the file, and share it with support-share@figma.com so they can take a closer look.

Same here! Post says it’s solved, but it’s not solved at all. I already submitted the form just a few moments ago, including the screen recording.