“Go to main component” button is gone (read below)

Please fix the bug that makes the “Go to main component” button in the right menu disappear for no apparent reason at all. If the library is inaccessible, try to open it anyway.

Apparently for some people this is also a problem in the assets tab: Where has the "Go to main component" button disappeared in assets? — I haven’t checked myself.

Here is an instance selected that has this button:

And here is where it doesn’t appear:

The difference? There is none. (upd: see my comment below, turns out this component is from a library I can only view) I just switched the component with my plugin Master to what basically is a copy of the old component in a different library. And the button disappeared.

At first I thought this is related to how some libraries are missing or you are not invited to them so you can’t go to main component. This is absolutely terrible UX but may be not a bug — just an intentional regression.

However, the behavior I’m experiencing is definitely a bug. Both of these libraries that I’m switching between belong to me. I just created them and published them.


Hi @Gleb thank you for brining this to our attention, I’ve raised this with our engineers. Are you able to invite support-share@figma.com with “can edit” permission to the effected files and share the file links so we can look into this further?

Yep I emailed support after posting this and shared the files.


Having this problem right now! Argh. Thanks for flagging @Gleb.

Got the reasoning from support after a lot of back and fourth, turns out the button disappears for two reasons:

  1. You don’t have access to the library — the button disappears so you can’t open the library link.

  2. You do have access to the library but only as a Viewer. This one makes zero sense to me so I sent an additional inquiry. Update: it happens because I have access to this library using a public view link but I was not invited to this file directly by email.

The second point seems like quite a big regression for design systems users for example, who usually don’t have edit access to libraries they are using. Also for developers who need to go inspect a whole component set that’s used in the screen.

Also again just showing the button greyed out with an explanation would be a much cleaner and usable solution.

1 Like

Hi! Is anyone going to solve this problem?

1 Like

I also have this problem! When will there be a decision?

1 Like

The solution for me was to move the project to another team because initially it was in the team which doesn’t contain the shared library.

Hi, I also have this issue. And it is really annoying. I think this should have priority.
Because this is what we do right, back and forth between library and prototype…
Any update on when this is solved?

1 Like

Make sure you have explicit access to the library file and not just access by link (the owner needs to invite you by email), or make sure you are a member of the team/project where this file is.

Figma pretty much said this feature won’t be reverted. Copying response from support:

In regards to this change, the previous way this worked was a security risk as it allowed people to access files that had never been explicitly shared with them. Your suggestion of "when you hover the icon it says “Library is inaccessible” or “Library is missing” or “You don’t have access to this library” sounds like as good suggestion to me, and I’m more than happy to push this as a feature request, however, this will not be reverted.

When users share files, it is not explicit that they’re sharing more than just that specific file. They do not say that they want to share every viewable library connected to that file. If someone does not give explicit access to a file, it is a security risk for us to give that access, even if technically they would have viewer access on that file.

I understand that in a lot of cases, this security risk doesn’t matter that much, and that there are a ton of cases where this is going to be annoying. However, there have been cases where users have explicitly flagged this as a security risk that is a big deal to them and has caused real harm.

1 Like

Yo Figma?
Where is Button “Go to main component”?
Now, as a user, I must look for what I need visually or by searching the components file separately. If I have more than 1000, what should I do?
This is not serious!!!

Hi! If you switch to “Dev Mode” and select library component, in the right panel show “Go to main component” icon

1 Like

Hm, I have an UI kit in another project folder set invited only. Then moves instance design file to another project folder and the icon disappear even though I’m the owner of that UI kit. That disappoints me, cuz I’m working on project and will update the UI kit while using it.

1 Like

Same issue here. In the “Desktop app” the button is gone but in the browser its still there…

Serious issue for me!

1 Like

Pretty classic bad design decision if you ask me.

1 Like

There used to be a menu item for this.
Object > Main Component > Go to Main Component.

This option is now gone. I was using an accessibility app to trigger that menu bar command without needing to use my mouse and that doesn’t seem possible anymore. Can we get a keyboard shortcut for “go to main component” please?


I see many people have been asking the same over the years… Hopefully this will get fixed.


The terrible UX downgrade just got even worse with this.

1 Like

I understand that the Go to Main Component will not come back for all files.

With that said, can you add a feature that tells the designer why he/she cannot access the main component (e.g. “you don’t have access to the component file…”), and where he/she/they can request the Edit permission?

1 Like

Yes this works!

I have been editing and maintaining the master component library since its creation, so have access and am an editor. But today I created a new Figma file, linked the library, but the “go to component” button does not show. It seems silly that i would have to be invited by email to edit a file i’ve been editing for months, is there something else that needs to happen?