Fonts not updating

I installed a font on my Mac and it loaded into Figma but registered as 4 different fonts based on styles of the font (e.g. book, medium, bold, black). So I went into FontBook on my Mac and reinstalled a different version of the font. It loaded perfectly into other programs but Figma still displays it as four separate fonts and they aren’t even the complete set so it isn’t usable as is. What can I do about this? Is there any way to delete the current reference or force Figma to re-register the font?

Things I have tried: reloading, web vs. desktop app, deleting the app and reinstalling.

Remove the broken fonts from Font Book. Figma doesn’t store/cache fonts in any way, they are always loaded from your computer when opening the Figma file.

Thanks Gleb, that was basically what I ended up doing. Deleted the fonts, opened Figma to confirm it was not there, quit Figma, installed the font, opened Figma and boom.

It seemed as though Figma apparently will retain the old version of the font if Figma is not open but you uninstall a font and re-install a different file of the same font. It doesn’t replace the font it assumes it’s the old one. This is weird because you said there is no cache. Wonder why.

What font is that? If it’s from Google Fonts, it would be automatically included in Figma and you need to disable “show google fonts” in preferences if you want to use the locally installed version.

It was a company font called Circular Pro. I had a sus version that seemed incomplete, which was giving me problems, but I got the complete version from the Client and that worked fine.