Font Style unexpectedly has been disconnected from library

I’m not sure why this happened, but all styles in our component has been disconnected unexpectedly. Color tokens have been connected without any problem.

I’ve checked the previous version using version history, and found that it happened around the end of December 2022 or so(3 weeks ago).

Does anyone know the reason, and how to solve this?
It takes huge time if we take care of them manually… :scream:

1 Like

I have noticed my fonts disconnecting just about every day, within the last week. I don’t know why this keeps happening and it is so frustration. I have to completely log out of Figma and then log back in for it to correct itself.

1 Like

It happened to me to, and I found the reason why this happens as well.

1 Like

I’m not sure that this is my issue. My text styles seem fine all day long. But, when I come back the next day, they are detached from all of Figma…as if I did not download the font family. It wants me to replace the fonts if I try to edit the copy. So…to fix, I have to log out and log back in. Not sure this is the same thing as the copy and paste from a section.


We have the same bug in Figma that makes the font style go crazy when editing the text. It’s super frustrating and a waste of time to fix it by hand every time. Does anyone have a solution for this? We tried logging out and in but it didn’t work. Appreciate any help.

Hi @Gili1 , sorry to hear you are having trouble with font style!

The bug has been solved a couple months ago, but your issue may be a new bug. Please submit a bug report to the support team so we can investigate further. Thank you!