Figma Support Forum

Font style name is different in Edit and Inspect mode

Hi,

Im working on a file where I predefine name for each font style. Somehow inspect mode show different style name.

Example
Edit mode: Font style name is ‘Large Paragraph/Medium’
Inspect mode: The same font style name is ‘h5/Medium’

Im attaching preview where the selected elements is exactly the same.

7 Likes

@Figma_Support @FIGMA137 the same happens for me too. The Text Styles are shared across multiple files.

Can you reproduce?

2 Likes

@Figma_Support I am also hitting the same issue.

It has happened after changing the style names for the font style. The edit tab has the new updated name and the inspect has the old.

Example:

I have found if you go through and unset the font style and re-set it. It then updates, but this is not really viable to do on every text box in a large project like I’m working on.

Is there a manual refresh style button we can use?

Any fix would be great as this is causing a big problem when the designs are being developed as developers are given style names that don’t exist.

4 Likes

I’m experiencing this same bug on my end as well.

I tried running the [Regenerate all instances (slow)] command, but that didn’t fix it.

I also tried clearing my cache and doing a hard refresh, but that didn’t work either.

1 Like

Having the same issue, was hoping to find a solution here. Very annoying becuse I want to keep the style names up to date for developers :confused: