Figma zero bytes on install

I have tried downloading the Figma for Mac app and when I download the zip file, it shows up how it should. (with the app logo filled in and shows the app is 1.4 MB. However, after I move it to the applications folder and then try to open the app, it changes to a blank icon and says it can’t be opened because it’s damaged or incomplete. I’ve done this multiple times on different days with new downloads and refreshed my computer and same results.

Try to download from the direct link:


Life saving.
Figma Team, could you add link for this to the download Figma page?

As many others here, I can’t download the Figma app’s newest version. Other topics were closed so I’m opening it here again.
Error: can’t be opened because it’s damaged or incomplete.
Because I replaced it with the old version I don’t have a working desktop version anymore.
Dear Figma team, please provide us with old versions that can be downloaded.

Macbook: Big Sur 11.4 with Intel chip

1 Like

Looks like that some buggy rollout happend :frowning:
Hopefully they fix asap.

1 Like

Hey Figma guys!

The problem still exist and continued. Details are still the same like in closed long lived topic with the same name.

Please, slap some devs to dig and fix, that’s not cool that forced update just killed my ability to work!!!

1 Like

If that helps:

  • Launch install app from “Applications” folder
  • It doesn’t ask any permissions (non-admin account)
  • After downloading and finishing the Package Contents of “” is empty at all.

hi there

i seem to have an issue with the M1

  • download the .zip file
  • extract and move to Application folder
  • double click to install
  • it ends up being installed with 0 bytes size and a ‘do not cross’ sign

any ideas why this might happen ?

Hey @John22,

Sorry for the trouble. Can you please try downloading and installing from the direct link?

1 Like

Hi @dvaliao ,

direct link app works as expected,

thanks a lot

1 Like

What happens when you update directly from the app via the figma > check for updates menu

I had zero problems with mine. Zero bites means Safari hadn’t downloaded it. Try again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.