Figma "Update available" doesn't work for me

Hello,
I have a problem for a while now with both my personal account and my pro account, when it comes to update Figma, whenever I open Figma I get this modal with an “Update available” and when I press “Install now” Figma quit for a few seconds before opening with the exact same modal. I’d do it a few times, get tired of it and then press “Install on next launch”

Hey Maram! Sorry for the trouble.
Can you please try to reset the cache for the Figma desktop app, then let me know if you are still experiencing this issue.

You can clear the desktop app cache in the Help menu under Troubleshooting.

If you’d prefer to clear your cache manually, please follow these steps:

Mac

Use the Terminal app to clear the cache.

  1. Quit the Figma desktop app.
  2. Open the Terminal.app and enter the following command: rm -rf "$HOME/Library/Application Support/Figma/"{Desktop,DesktopProfile}
  3. Try opening the Figma desktop app again.

Windows

Run a command line from the Start menu.

  1. Close the Figma desktop app.
  2. Open the Start menu and paste the %APPDATA%\\Figma command. Press the Enter key to submit.
  3. In the window, delete the DesktopProfile folder.
  4. Launch the Figma desktop app again.
1 Like

So I did as you said and cleared the cache using the help menu, unfortunately I’m still facing the same issue :frowning:

Thanks for letting me know Maram! Can you please try to fully uninstall all Figma apps using an app remover and then restart your computer and try to install the latest version at this guide “Download the Figma Desktop App” here: https://help.figma.com/hc/en-us/articles/5601429983767

You can also check the system requirements to run the Desktop App in that article. If your computer doesn’t meet our requirements you may also see an error on installation which we won’t be able to resolve for you.

If a new installation doesn’t clear this error and you meet all of the requirements shown in that article, please send us a screenshot of your system specs and any error messages you see by filling this form here: https://help.figma.com/hc/en-us/requests/new Our support team will be happy to trouble shoot with you. Thank you!

1 Like

Hello, thank you ! It worked, I didn’t even restart my computer and it still worked :grin:

1 Like

Ahh perfect, glad it works now! :smiley: