Figma Slides: publish template error

When I try to publish a Figma Slides template, I get this message:
“Something went wrong while publishing. Refresh the page and try again.”

I’ve restarted Figma and have re-tried a number of times. Can you suggest anything? Thanks

Hey @Daniel_Benney – just to make sure I’ve got all my bases covered and understand correctly:

Are you on an organization or enterprise plan?

You’re having trouble publishing a custom template as described in this help page, correct?

@ksn Hi Kim, I believe we’re on a organisation plan.
Yes, that’s correct. When I click “publish” I have the option to save to Team or Organisation and neither work at the moment.

Thanks, Daniel – cab you try a list of things for me?

  1. It sounds like you’re on the desktop app – can you clear your app cache to see if that get things moving? Steps here.

  2. Can you try duplicating the template file you already have, and then try publishing the duplicate to see if that works?

  3. Just to cover all bases – can you try publishing on the web version of Figma?

Also, to verify – you are an admin/owner of the team you’re trying to publish the template to, correct?

Let me know when you can – I did some testing on my end, and didn’t run into any issues with publishing templates, so I’d like to eliminate some potential issues with you trying the suggestions above. Thank you!

Hi, we’ve tried a few things:

  • Clearing cache didn’t work
  • Duplicating didn’t work
  • Haven’t had a chance to test admin rights yet

We’ve also tried:

  • Adding the content of this presentation to a file that was publishing (copy and paste) and that seems to work. Not sure why that is but we’ll keep experimenting.
  • Our main file contains components copied from a Figma file, so we wondered if that made a difference but it hasn’t seemed to.

Hey @Daniel_Benney ,
I am working closely with Kim. Thanks for these details!
This looks odd that these workarounds don’t help. Not sure the root cause of this, I’ve gone ahead and redirect you to the support team via email directly so they can investigate it further via email. For your information, your ticket number is #1066193 , and I sent a message to your Figma email account hello@dxxxxxxxxxxy.com. Thank you!

Awesome, thanks @Celine_Figma.

Update: I’ve now created a file that will publish by copying and pasting between files. I’ve been able to recreate all slides this way. So I’m not blocked anymore, but it would be useful to know what the issue was.

1 Like

Ah glad it’s working now, thanks for letting me know!

Hi can you expand on what you mean by this? I am having the same Problem.

Hi @Jeffrey_Potter. Here’s the story so far: I made a template in Figma Slides and tried to publish it. I got an error. The only way I’ve found to publish the contents of those slides is:

a) Create a simple template (maybe just one page) and publish that.
b) Copy and paste content from the original file into the new file. But… publish the file page by page so you can find out which slides are causing the issue.

Does that help ?