Figma library not detecting changes

My Figma library is not detecting changes when I make them. It is driving me nuts. Other designers can see the changes though and are able to push them for me. My Figma just says: ‘Published and up to date’

I tried:

  • Using another account
  • Reïnstalling Figma (and deleting all the subfolders and logging)
  • The browser version
  • Checking if any layers are prefixed with ‘_’
  • Renaming components

Nothing works… any suggestions?


Same for me.

Hey all this should now be fixed. Can you try refreshing?

I’m still having this issue

See if any components thath you specifically made contain any unused properties. Exclamation circle when checking the component will indicate this state.

This causes a publishing bug for the author of the changes. Others can load the changes but you wont be able to reload your library until you resolve the missing/unused properties

Ive spent good 4 hours yesterday trying to figure out why my combobox component was fine when copied, but did not work when selected from the library menu.

This helped me, maybe that will help you


It works for me. Thank you for advice.

Thanks a lot! Worked for me, as well.

You’re a lifesaver. Thank you.

OMG this thread was a life-saver this has been plaguing me and destroying files for MONTHS

Bro thank you so much

Worked for me too

I’m having this problem. And I’ve already tried everything mentioned above.

Sorry to hear the above solution didn’t work for you, @Thaisley!

Please reach out to the support team directly via this form for help:

Be sure to use your Figma account email, include a link to the file, and share it with, so they can take a closer look.

Worked for me too. A year later. Thank you :green_heart:

1 Like