Figma desktop notifications on macOS

I’m not receiving system notifications on macOS using the desktop app, despite having this enabled in the app settings. I tried reinstalling and nothing happened. Figma never ask system permissions to show notifications, thus there’s nothing I can enable on macOS settings.

Does anyone know what could I try? (besides reinstalling, which I have already done).

Hey @Javier9, thank you for reaching out!

As a first step can you please try clearing your desktop app cache here? And check if your MacOS is running on 11 or later.

You can clear the desktop app cache on a Mac in the Help menu under Troubleshooting. If you’d prefer to manually clear your cache you can:

  1. Quit the Figma desktop app
  2. Open Terminal.app and enter the following command: rm -rf “$HOME/Library/Application Support/Figma”
  3. Try opening the desktop app again

If clearing the app cache does not help can you also please do the following?

  • Make sure “Show Figma in Menu Bar” is enabled.

  • Close the file tab on which you expect to receive push notifications

Can you also provide/check the following?

  1. Your device’s OS version and the Figma desktop app version
  2. On your device’s notification settings, do you see Figma listed as an app with desktop notifications on?
  3. In the Figma app notifications settings, which option do you have selected?

Thanks,
Gayani

Hi there, I just wanted to make sure that this is a requirement to get notifications? Because I don’t really need it and I don’t have it on. I’m just interested in the system notifications without having Figma on the toolbar.

Thanks!

Hey @Javier9, apologies for the delayed response! I’ve got the confirmation from the support team that this is a requirement to get notifications. You can find more information in our Help Center article: Manage your notification preferences.

Are you receiving system notifications now?