Figma changing the Paste to replace shortcut again

Anyone noticed that Figma changed the Paste to replace keyboard shortcut?

Until yesterday the shortcut was: Command + Option + Shift + V
Now is Shift + Command + R, and I think it doesn’t quite communicate the pasting part of the function

Hope they reverse this “up-date” because is being annoying me all morning.

Continuing the discussion from Why did Figma decide to change the "Paste to replace" keyboard shortcut?:


Yes! I tried pasting some stuff this morning and was super confused when it wasn’t replacing it :upside_down_face:
R to paste is not intuitive at all


Yes same! Much prefer the older shortcut, I associate “v” with pasting, and modifier keys change the paste behavior.

Very much hope this is a test or can be changed back.


Agree! “Paste to Replace” should be more prominent than “Paste Over Selection”. Much prefer the old shortcut :pray:

1 Like

Hi, all!

I was a happy person using the Cmd+Opt+Shif+V shortcut when pasting to replace, and I know that Figma tried to change the paste-to-replace shortcut to Cmd+Shift+R before, but it got back to Cmd+Opt+Shif+V as it seemed more natural for users.

Now it is again using Cmd+Shift+R, and I am a sad person.

For me, using the old one makes more sense as it shares the V key all over the paste options, only using Cmd, Shift and Opt as modifiers.

is there any real reason it changed to Cmd+Shift+R? For me, it seems nonsense. Can’t you roll it back to the Cmd+Shift+Opt+V? You would make me and other designers happy again.


It’s nice to see I am not the only one going a bit less sane over this the whole day. All the time, I thought it was me or the keyboard doing wrong. Damn.

1 Like

I cant understand why? I prefer the old one

1 Like

Oef had the same thing, my brain is not adaptable enough to change the shortcut in my head and hands :frowning: Have been using the ‘cmd+opt+shift+v’ combi for my entire live


I have the same problem, fighting with my muscle memory when pasting to replace.

I was thinking of replacing the shortcut with the “old” one via the Mac preferences in the keyboard, overriding Figma shortcut as a workaround, but apparently I can’t override the default one with this:

Any other suggestions?

Edit: Restarting Figma after changing the shortcut in the Mac preferences worked :rainbow:


bring the old one back!!!


It is a great workaround, but it didn’t work for me. :frowning:

I hope they restore the old shortcut.

and it’s far less ergononic to hit those keys, my wrist have to break in a weird angle

Same here. I’ve been using this shortcut since the beginning.

Nice try Figma, but bring the old shortcut back. It’s not a nice thing to change such an important shortcut overnight… :rage:

Extremely frustrating, it’s not like they reassigned Cmd+Option+Shift+V to anything else more useful… really hope they change this back

Hey All, thank you so much for your feedback!

The team did make recent changes to the Paste to replace shortcut thinking that it would be more consistent/predictable, but we hear your frustration and understand now that it was the wrong move.

The team is already discussing and hoping to push a fix - stay tuned!


Tried this morning and it was fixed back to the old good Cmd+Option+Shift+V, although it still works with Cmd+Shift+R we all know the old one is better. :slight_smile: Thanks